Suporte » Ajustando o WordPress » Editor visual não aparece corretamente

  • Resolvido fabianotecnico

    (@fabianotecnico)


    Título original: HELP – Meu Editor de Texto SUMIU o MODO VISUAL

    Olá

    Galera Beleza?

    Depois que atualizei o meu site para a nova versão do WordPress 3.1, apresentou problema no EDITOR de TEXTO, o modo HTML está OK, porém, quando clico no modo VISUAL para exibir as opções ele acrescenta automaticamente no painel do POST esse texto: “” e fica só nisso, o EDITOR DE TEXTO de modo visual, SUMIU as OPÇÕES (botões de justificar, alinhar, negrito, formato de tamanho de texto (h1,h2…etc) TODOS esses BOTÕES SUMIRAM. Porém, os BOTÕES do MODO HTML, está OK. Cheguei a desativar todos os plugins, porém, sem sucesso.

    Alguém sabe como resolver?

    Agradeço!

Visualizando 13 respostas - 1 até 13 (de um total de 13)
  • Isso já aconteceu na primeira vez que eu instalei o WordPress, quando eu era iniciante e não tinha muita noção sobre WordPress e instalei o sistema fazendo upload dos arquivos 1 por 1.

    No meu caso o que resolveu foi uma reinstalação.
    Mas te aconselho que faça manualmente pois também tive problema com a atualização automática e agora só faço manual.

    Baixe o wordpress em portugues em formato .zip faça upload para o diretório onde se encontra sua instalação WordPress e descompacte que vai subistituir todos os seus arquivos da instalação anterior.

    Lembre-se de salvar seu wp-config.php antes.

    Bom,isso não resolveu no meu caso,já reinstalei o WordPress cerca de 10 vezes,(ou até mais)até com versões antigas,novas ,em inglês etc… vou logo falando que não entendo quase nada de wordpress,etc meu blog está hospedado no Awardspace (um site que oferece subdomínios gratuitos)fora esse bug,quando logo no wordpress e entro na página da dashboard os menus”blog do wordpress” e “outras notícias do wordpress” me dá este erro:RSS Error: WP HTTP Error: couldn’t connect to host ,não criei outro tópico pra minha pergunta porquê achei que seria repetição…

    Consegui resolver seu problema,fabianotecnico era no arquivo wp-tinymce.js.gz que fica na pasta wordpress/wp-includes/js/tinymce/wp-tinymce.js.gz

    No meu caso ele não funcionou devido ao awardspace não dar suporte a arquivos .gz ,eu tive de fazer uma modificação no arquivo wp-tinymce.php pra que ele não tente descompactar o wp-tinymce.js,mas meu segundo problema não foi resolvido…

    É só você copiar o arquivo wp-tinymce.js.gz para a pasta wordpress/wp-includes/js/tinymce/caso você use o awardspace ou outro site que não suporta aquivo .gz descompacte o wp-tinymce.js.gz ,faça o upload do wp-tinymce.js na pasta do tinymce , e modifique a parte final do arquivo wp-tinymce.php para:

    //if ( isset($_GET['c']) && 1 == $_GET['c'] && isset($_SERVER['HTTP_ACCEPT_ENCODING'])
    //	&& false !== strpos( strtolower($_SERVER['HTTP_ACCEPT_ENCODING']), 'gzip') && ( $file = get_file($basepath . '/wp-tinymce.js.gz') ) ) {
    
    if ( isset($_GET['c']) && 1 == $_GET['c'] && isset($_SERVER['HTTP_ACCEPT_ENCODING'])
    	&& ( $file = get_file($basepath . '/wp-tinymce.js') ) ) {
    
    	//header('Content-Encoding: gzip');
    	echo $file;
    } else {
    	echo get_file($basepath . '/tiny_mce.js');
    }
    exit;

    e é isso 😉

    Criador do tópico fabianotecnico

    (@fabianotecnico)

    Olá

    kawky

    Obrigado pela resposta, VALEU MESMO.

    Infelizmente, não consegui resolver o problema mesmo assim, porém, como é um BLOG que ainda estou inserindo dados nele, fiz a instalação do ZERO novamente e agora deve dar certo.

    Mas muito Obrigado, pelas dicas.

    Valeu
    Fabiano

    Aqui tem uma possível solução (veja até mais abaixo na página):
    http://wordpress.org/support/topic/troubleshooting-wordpress-31-master-list?replies=30

    Dia desses eu quase perco meu site. Uma dica, não atualizem o WordPress automaticamente pois é muito perigoso dar erro.
    A melhor forma é pelo manual mesmo.

    Tive este mesmo problema, fiz o seguinte vá até usuários -> seu perfil, la vai ter uma caixinha com uma opção desativar o editor visual ao escrever. Simplismente desmarque ela. Comigo funcionou perfeitamente

    Descobri o erro, remova o plugin contact form 7 ele que gera o erro, e se não funcionar vá até seu perfil em usuários e desmarque a opção ocultar editor visual ao escrever.

    Obs no 3.1

    WP3.1 – desativa o plugin “Artiss YouTube Embed”

    Eu tinha o mesmo problema, mas foi resolvido com a solução do Kawky.
    Mas ao invés de subir os arquivos wp-tinymce.js e wp-tinymce.php eu tive que subir pro servidor a pasta toda, não sei porque, mas funcionou.
    Obrigado pela dica

    Tive o mesmo problema.

    Solução: colar na última linha do ‘wp-config.php’:

    define('CONCATENATE_SCRIPTS', false );

    Realmente a Solução de Kawky funciona!

    Vlw irmao! =)

Visualizando 13 respostas - 1 até 13 (de um total de 13)
  • O tópico ‘Editor visual não aparece corretamente’ está fechado para novas respostas.