Suporte » Ajustando o WordPress » Habilitar a função de auto salvar os rascunhos de um post

  • Resolvido jujuba78

    (@jujuba78)


    Percebi que de umas semanas para cà, meu WP deixou de salvar automaticamente meus rascunhos. Procurei nas configurações e não achei a opção.

    Hoje, enquanto fazia a revisão de um post antigo (e foi uma longa revisão), meu navegador fechou e perdi toda a revisão feita. Antigamente, quando eu abria um post que não havia sido salvo corretamente, ao retornar no post, ele me notificava que havia uma revisão mais recente e me perguntava se eu queria analisà-la.
    Hoje eu não recebi nenhuma mensagem e, no campo correções, apareceu apenas 2 que eu havia feito ontem (antigamente apareciam inúmeras revisões).

    Nao acredito que eu tenha instalado algum plugin que alterasse isso, mas tive um problema com banco de dados semanas atràs e o técnico de suporte de meu serviço de hospedagem arrumou. Não sei dizer se essa mudança ocorreu na mesma época.

    Sei que muita gente procura saber como desabilitar essa função, mas eu gostaria de reabilitar!

    ps: Consta em meu wp-config.php esses codigos:

    define(‘AUTOSAVE_INTERVAL’, 30);

    e mais abaixo

    define(‘WP_DEBUG’, false);
    define(‘WP_POST_REVISIONS’, 2);

    Em meu post-new.php :

    // Schedule auto-draft cleanup
    if ( ! wp_next_scheduled( ‘wp_scheduled_auto_draft_delete’ ) )
    wp_schedule_event( time(), ‘daily’, ‘wp_scheduled_auto_draft_delete’ );

    wp_enqueue_script( ‘autosave’ );

    Obrigada,

Visualizando 15 respostas - 1 até 15 (de um total de 16)
  • Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Olá @jujuba78, tudo bem?

    define('AUTOSAVE_INTERVAL', 30); significa que seus posts irão salvar a cada 30 segundos.

    define('WP_POST_REVISIONS', 2); significa que o WordPress irá salvar no máximo 2 revisões.

    Sendo assim, retire essa linha: define('WP_POST_REVISIONS', 2); e o WordPress irá voltar a salvar quantas revisões forem necessárias.

    Ah! Queria sugerir que use a tag code para pedações de código aqui no Fórum e se forem muito grandes, use algum serviço como Gist ou Pastebin.

    Sobre o que consta em post-new.php: por favor, nunca altere arquivos do Core e na dúvida sobrescreva com novos arquivos baixados (na mesma versão, claro).

    Abraços

    Criador do tópico jujuba78

    (@jujuba78)

    Olà Mario Valney

    Muito obrigada pela resposta e pela sugestão da tag code (eu realmente não sabia), mas como imaginei, não funcionou!

    Na verdade eu inseri hoje aqueles dois códigos no wp-config.php apòs procurar ajuda e como não deu certo, busquei ajuda aqui!

    Nao sei se tem alguma relação, mas quando termino de revisar um post e salvo a alteração feita, recebo a mensagem de post atualizado. Até aì, tudo bem! Mas se na sequencia, se tento fechar a pàgina, recebo a mensagem de que preciso salvà-la para não perder dados!

    Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Então retire aqueles códigos que você adicionou hoje e vamos tentar achar o problema original.

    O primeiro passo é desativar todos os plugins e voltar para o tema padrão.
    O problema deve parar de acontecer, se parar, então volta o tema que você usa e verifica: se ainda está OK, o tema não é o problema, se parar de funcionar, sabemos que é o tema.

    Isso se repete voltando um plugin por vez até achar o que está causando.

    Se quando voltar tudo para o padrão não resolver, me avisa.

    Abraços

    Criador do tópico jujuba78

    (@jujuba78)

    Valeu Màrio
    Era tudo o que eu não queria fazer!
    ;(
    Se persistir, te aviso!

    Abraços e muito obrigada!

    Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Infelizmente é a melhor forma de achar o erro.

    Mas faz o seguinte… antes disso poderia verificar se tem algum erro no console?

    1 – Basta apertar F12, se for no Chrome ou então clicar com o botão direito do mouse na tela e ir até “Inspecionar Elemento”.

    2 – Na área que abrir, procure pela aba “Console”.

    Se tiver algo vermelho, por favor, copie e cole aqui (use “code” para melhorar a leitura ou o gist/pastebin se for muito grande).

    Abraços

    Criador do tópico jujuba78

    (@jujuba78)

    Apareceu erro em vermelho sim:

    /wp-admin/admin-ajax.php Failed to load resource: net::ERR_NETWORK_CHANGED

    Criador do tópico jujuba78

    (@jujuba78)

    Porém esse erro apareceu apenas no post pronto; Quando abri um post em branco, não apareceu nenhum erro.

    Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Olá /wp-admin/admin-ajax.php é o endpoint para tudo que é Ajax no WordPress, então também é usado pelas revisões.

    Limpe o cache no navegador e tente novamente, por favor.

    Se não resolver, tente acessar seu site de outro navegador, outro dispositivo e/ou outra conexão e verifique se também aparece esse erro (ou se as revisões funcionam).

    Pode ser apenas um bloqueio no navegador, dispositivo e/ou conexão.

    Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Ah… uma pergunta: no post em branco as revisões eram guardadas?

    Criador do tópico jujuba78

    (@jujuba78)

    Limpei o cache e não deu certo nem no Chrome, nem no Firefox e nem no Edge. Fiz o login por celular e também nao salvou.

    Antes, quando eu abria um post novo, mesmo que eu não escrevesse algo, o post era salvo e eu tinha que renomear o nome dado por eles (normalmente nùmeros). Se eu mudasse de ideia, tinha que deletar.

    Isso deixou de acontecer e creio que tenha sido na mesma época que meus rascunhos deixaram de ser salvos automaticamente.

    Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Exato. Tudo isso é feito via Ajax (é quando o seu navegador em tempo real manda requisições via Javascript sem precisar recarregar a página).

    Tentou com outra conexão (celular via 3G, por exemplo, ou outro lugar)?

    • Esta resposta foi modificada 4 anos, 2 meses atrás por Mario Valney.
    Criador do tópico jujuba78

    (@jujuba78)

    A ùnica conexão diferente que uso é o 4g do celular. Fiz o teste e não salvou o post.

    Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    É :/

    Então parece ser um problema no site mesmo… vai ter que fazer aquilo que eu disse lá em cima mesmo.

    Ah! Seu site está público? Tem o link?

    Abraços

    Criador do tópico jujuba78

    (@jujuba78)

    Acho que é o jeito mesmo!

    Està pùblico sim: http://www.turistando.in/

    Criador do tópico jujuba78

    (@jujuba78)

    Olà Mario

    Descobri o plug-in (WP Super Simple Speed) que não permitia o autosave de meus textos .

    Muito obrigada pela ajuda!

Visualizando 15 respostas - 1 até 15 (de um total de 16)
  • O tópico ‘Habilitar a função de auto salvar os rascunhos de um post’ está fechado para novas respostas.