Suporte » Temas » Exibição thumbnails – sem solução a vista

  • Resolvido wilsonmaia

    (@wilsonmaia)


    Eu estou usando o tema JournalCrunch e os thumbnails não aparecem na página inicial, apenas quando abro os posts. Página DOC
    Tentei várias dicas postadas aqui no fórum, em diversos templates, mas o resultado é sempre o mesmo, fracasso. Se alguém puder me ajudar com esse problema ficarei grato. Já fiz mudanças no timthumb.php e também não obtive resultados.
    Meu site é http://www.bebedegrife.com.br/blog

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • Myst1010

    (@myst1010)

    Criador do tópico wilsonmaia

    (@wilsonmaia)

    Então, o problema é que eu uso o picasa, assim as fotos ficam em outro servidor já que possuo pouco espaço de armazenamento. Com as imagens externas essa opção perde a sua funcionalidade.
    Pensei se teria outra maneira, no caso, usando imagens de outro servidor.

    Myst1010

    (@myst1010)

    Então acho que vc precisa de uma função semelhante a essa

    /*Créditos
    http://www.wprecipes.com/how-to-get-the-first-image-from-the-post-and-display-it */
    function catch_that_image() {
      global $post, $posts;
      $first_img = '';
      ob_start();
      ob_end_clean();
      $output = preg_match_all('/<img.+src=[\'"]([^\'"]+)[\'"].*>/i', $post->post_content, $matches);
      $first_img = $matches [1] [0];
    
      if(empty($first_img)){ //Defines a default image
        $first_img = "/images/default.jpg";
      }
      return $first_img;
    }

    Adicione a função ao function do seu tema e no home.php troque a chamada da imagem de destaque pela chamada da função com isso

    <?php echo catch_that_image() ?>

    Simplificando:
    onde está

    <?php
    if(has_post_thumbnail()) {
    //the_post_thumbnail();?>
    <img src="<?php bloginfo('template_directory'); ?>/timthumb.php?src=<?php echo get_image_path($post->ID); ?>&h=90&w=255&zc=1" alt="<?php the_title(); ?>">
    <?php } else {
    echo '<img src="'.get_bloginfo("template_url").'/images/nothumb.jpg"  alt="No Thumbnail"/>';
    }?>

    vc deixa

    <img src="<?php bloginfo('template_directory'); ?>/timthumb.php?src=<?php echo catch_that_image(); ?>&h=90&w=255&zc=1" alt="<?php the_title(); ?>">
    Criador do tópico wilsonmaia

    (@wilsonmaia)

    Não funcionou, tentei algumas outras coisas mas também não obtive sucesso. Vou tentando por aqui. Obrigado pela ajuda.

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • O tópico ‘Exibição thumbnails – sem solução a vista’ está fechado para novas respostas.