Suporte » Ajustando o WordPress » Nome de arquivos com acentuação não geram links acessíveis

  • crashnet

    (@crashnet)


    Título original: Essa é para os mestres: nomes de arquivos em unicode

    Ffiz upgrade de uma versão mais antiga (acho que era 2.8.x ou 2.9.x) para 3.1.2 e todos os arquivos de imagem que foram enviados pelo autor do blog utilizando acentos da língua portuguesa no nome agora são geram links quebrados.

    Por exemplo, onde o nome do arquivo enviado era EXPRESSÃO1.jpg, as referencias funcionavam perfeitamente – a imagem era mostrada. não sei se o link que o WP mandava para o browser era EXPRESSÃO.jpg ou EXPRESSÃO.jpg ou alguma outra forma (com %029 etc), mas funcionava.

    Depois do update, os arquivos continuam com o nome EXPRESSÃO1.jpg, mas o WP escreve a referencia como EXPRESSÃO1.jpg e a imagem não é mostrada.

    Consegui, através de um perl script rodado via SSH, pegar o nome de todos os 244 arquivos que contém caracteres unicode no nome.

    Mas eu só não sei como é que faço pra resolver esse problema agora… com certeza a melhor maneira é modificar esse perl script para renomear os arquivos, só que além de pouco conhecimento de perl eu não sei que tabela seria utilizada para fazer essa conversão… não sei em que formato “Ô quer dizer “Ô…

    alguém por aqui já lidou com uma situação similar e pode oferecer algum insight?

    PS: todo o conteúdo de texto do wordpress está sendo formatado corretamente. o problema é só no nome dos arquivos.

    grato,

Visualizando 2 respostas - 1 até 2 (de um total de 2)
Visualizando 2 respostas - 1 até 2 (de um total de 2)
  • O tópico ‘Nome de arquivos com acentuação não geram links acessíveis’ está fechado para novas respostas.