Suporte » Plugins » Erro: Warning: call_user_func_array() expects parameter 1 to be a valid callback

  • Estou com um erro aparentemente no plugin Timeline Express. Não estou conseguindo achar esse parâmetro falado para resolver o erro. Alguém ja passou por isso ou tem alguma ideia do que posso fazer?

    // Avoid the array_slice if possible.
    				if ( $the_['accepted_args'] == 0 ) {
    					$value = call_user_func_array( $the_['function'], array() );
    				} elseif ( $the_['accepted_args'] >= $num_args ) {
    					$value = call_user_func_array( $the_['function'], $args );
    				} else {
    					$value = call_user_func_array( $the_['function'], array_slice( $args, 0, (int) $the_['accepted_args'] ) );
    				}
    			}
    		} while ( false !== next( $this->iterations[ $nesting_level ] ) );
    • Este tópico foi modificado 3 anos, 2 meses atrás por pgzn.

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 5 respostas - 1 até 5 (de um total de 5)
  • saudações @pgzn,

    você já testou o básico de desabilitar todos os plugins (menos o Timeline Express, óbvio)? E já testou usar o plugin com um tema padrão, como o Twenty Nineteen?

    sugiro criar um clone do seu WordPress e fazer esses testes. vendo o suporte do próprio plugin,

    https://wordpress.org/support/plugin/timeline-express/

    vi um tópico com o mesmo erro usando a pesquisa. e a pessoa respondendo levantou que o problema poderia ser com o tema. e vendo o código-fonte de seu WordPress não mostra a referência do tema, então é um tema Premium ou desenvolvido sob encomenda. o que em qualquer dos 2 casos, conforme regras do fórum, o suporte deve ser fornecido pelo desenvolvedor.

    boa sorte!

    Gassho, Ubuntu (“eu sou através do que nós somos”)

    Criador do tópico pgzn

    (@pgzn)

    Fala @ralden !

    Já fiz tudo isso infelizmente :/. Estou utilizando o tema Twenty Nineteen padrão e o OptimizePress para preparar as páginas.

    Limpei a cache, testei outros temas, pelo jeito ta parecendo ser algo entre os dois editores mas que não to conseguindo solucionar :/

    saudações @pgzn,

    pesquisei no suporte/documentação do OptimizePress o seu erro e achei a resposta abaixo,

    https://help.optimizepress.com/article/519-blog-error-warning–expects-exactly-1-parameter

    segundo essa resposta, a partir da versão 2.5.11 o usuário deveria usar o “new OptimizePress Smart Theme”. e como pelo código-fonte de seu site vejo que está usando a versão 2.5.19.1, indicaria testar usar esse tema indicado.

    caso não resolva, indico abrir um chamado de suporte diretamente com eles,

    https://optimizesupport.com/

    boa sorte!

    Gassho, Ubuntu(“eu sou através do que nós somos”)

    Criador do tópico pgzn

    (@pgzn)

    Mandei no suporte, mas acabei pensando numa possível solução.

    To pensando em desativar o debug, porém, já havia feito isso no debug do tema e não funcionou, será que existe a possibilidade de desativar o debug do plugin? Como isso não ta me afetando em nada só desativar é a melhor opção que tenho no momento.

    Sabe de algo?

    E valeu pela ajuda @ralden , tmj!

    saudações @pgzn,

    olha, não sugiro. o debug tem justamente a função de informar erros. você pode achar que não está lhe afetando, mas em algum momento pode precisar de algo que precise da função user e com certeza não vai se lembrar que desabilitou o debug, pois é uma questão técnica. (se eu não documentasse as mudanças que faço, estaria em maus lençóis, pois depois de algumas horas já não me lembro rs).

    o ideal agora é aguardar. inclusive, conforme as regras do fórum, quem deve fornecer suporte de temas e plugins pagos são os próprios desenvolvedores, pois o código não fica disponível para testes.

    se for possível testar a solução que apontei do tema, seria interessante. o OptimizePress é um sistema bem robusto para dar conta do que eles oferecem. então realmente precisa esperar o suporte pontual e correto deles.

    boa sorte!

    Gassho, Ubuntu(“eu sou através do que nós somos”)

Visualizando 5 respostas - 1 até 5 (de um total de 5)
  • O tópico ‘Erro: Warning: call_user_func_array() expects parameter 1 to be a valid callback’ está fechado para novas respostas.