Suporte » Plugins » Erro Pagamento Woocommerce

Visualizando 8 respostas - 1 até 8 (de um total de 8)
  • olá Guilherme,

    Fiquei intrigado com seu print, pois não aparece texto no alerta, apenas uma linha vermelha. Então fiz uma compra de teste no seu link.

    Após replicar o erro, vendo a seção Console do Inspetor, aparece o seguinte alerta:

    Screenshot

    Pesquisando na web, encontrei um tópico interessante aqui.

    Sugiro que experimento o procedimento indicado no tópico:

    1. Criar uma cópia de testes da sua loja (stagging);
    2. Verificar versão do tema (Colibri WP) e plugins, se atualizados;
    3. Verifique os templates do WooCommerce do tema, que pode ver em WooCommerce > Status > System Status (conforme documentação do WooCommerce aqui);
    4. Se o erro persistir, experimente ativar um tema padrão do WordPress, como os da série Twenty, e veja se o erro continua.

    Acredito que com esse procedimento, deve conseguir resolver o problema. Claro que se só resolver com o último ponto, significa que há algo no tema que escolheu que, neste momento, gera o problema. Neste caso, ou precisará escolher outro tema ou contactar o desenvolvedor e reportar o problema, solicitando uma atualização.

    Espero ter conseguido ajudar. Boa sorte!
    [gassho]

    Criador do tópico guilhermesouza007

    (@guilhermesouza007)

    Ola raiden , vou fazer todos os testes que me passou. Agradeço muito pela ajuda, se conseguir voltarei e deixarei aqui o que resolveu.
    😉

    Criador do tópico guilhermesouza007

    (@guilhermesouza007)

    @ralden testei aqui, infelizmente o problema permanece, mesmo trocando de temas.
    System Status, mostra td ok

    Criador do tópico guilhermesouza007

    (@guilhermesouza007)

    Ola achei o erro, esta no plugin WCMP, desativei e foi. Mas preciso dele, saberia como resolver?

    olá Guilherme,

    Nesse caso, é partir para o método “clássico” de testes: desabilita TODOS os plugins e coloque um tema padrão do WordPress. Claro que, após fazer isso, precisa habilitar os plugins essenciais para seu projeto, que eu acredito que são: WooCommerce, WC market place, e Brazilian Extra Fields.

    Eu sugiro que inicialmente não habilite o “WC market place”. Especialmente se for uma solução premium, como em https://wc-marketplace.com. E veja se o WooCommerce consegue processar uma compra de teste, com boleto. Se der certo, ai sim habilite o “WC market place” que usa.

    Outra sugestão: quando eu preciso fazer este tipo de procedimento, eu uso o https://br.wordpress.org/plugins/health-check/ (adoro este plugin!). Que permite na aba Resolução de problemas que ative este modo. É fabuloso porque somente o Administrador verá uma versão com todos os plugins desabilitados e o tema padrão ativo. Então pode ir ativando e desativando plugins, e verificando o resultado.

    Quando terminar todos os testes e entender que plugin pode estar quebrando seu site, basta desativar o Modo de Resolução de problemas e realizar os ajustes que verificou.

    Espero que isto possa lhe ajudar. Boa sorte!
    [gassho]

    Opa, se o erro está no WCMP, ai só tem basicamente dois caminhos:

    1. Aciona o desenvolvedor e verifica se ele indicaria alguma correção ou mesmo atualização para o bug;
    2. Partir para outra solução

    Inclusive não duvido que possa ser um conflito entre ele o Brazilian Extra Fields. Pois adiciona campos ao checkout que não são nativos do WooCommerce. E isso pode gerar algum conflito.

    Mas há outras possibilidades. Por vezes até a versão do PHP interfere em estar ocorrendo um problema.

    É realmente testar, debugar, talvez experimentar outras soluções. Até encontrar um conjunto que funcione como você deseja.

    Boa sorte!
    [gassho]

    Criador do tópico guilhermesouza007

    (@guilhermesouza007)

    obrigado @ralden , estou vendo com, suporte, se der certo volto para o feedback

    Criador do tópico guilhermesouza007

    (@guilhermesouza007)

    Ola @ralden , volto para o feedback. Depois de muita pesquisa e dicas de programadores, descobri que o WCMP volta 3 parametros, e nao 4 faltando o 4-party event($email) nos templates da loja do vendedor. Alterei o codigo e funcionou, acionei o suporte e na proxima atualização ja irão arrumar. Grato 😉

Visualizando 8 respostas - 1 até 8 (de um total de 8)
  • Você deve estar conectado para responder a este tópico.