Suporte » Gerenciamento de conteúdo » Erro no wp-includes/widgets/class-wp-widget-meta.php

  • Boa tarde, estou com um problema em site que fiz no wordpress .O site está fora do ar e o pessoal da locaweb disse que era nesse arquivo wp-includes/widgets/class-wp-widget-meta.php . vou mandar o código não sei se posso deletar esse arquivo para assim poder rodar o site… Não fiz o site pelo código então como saber o erro?

    att

    Stella

    //?php
    /**
    * Widget API: WP_Widget_Meta class
    *
    * @package WordPress
    * @subpackage Widgets
    * @since 4.4.0
    */

    /**
    * Core class used to implement a Meta widget.
    *
    * Displays log in/out, RSS feed links, etc.
    *
    * @since 2.8.0
    *
    * @see WP_Widget
    */
    class WP_Widget_Meta extends WP_Widget {

    /**
    * Sets up a new Meta widget instance.
    *
    * @since 2.8.0
    */
    public function __construct() {
    $widget_ops = array(
    ‘classname’ => ‘widget_meta’,
    ‘description’ => __( ‘Login, RSS, & WordPress.org links.’ ),
    ‘customize_selective_refresh’ => true,
    ‘show_instance_in_rest’ => true,
    );
    parent::__construct( ‘meta’, __( ‘Meta’ ), $widget_ops );
    }

    /**
    * Outputs the content for the current Meta widget instance.
    *
    * @since 2.8.0
    *
    * @param array $args Display arguments including ‘before_title’, ‘after_title’,
    * ‘before_widget’, and ‘after_widget’.
    * @param array $instance Settings for the current Meta widget instance.
    */
    public function widget( $args, $instance ) {
    $default_title = __( ‘Meta’ );
    $title = ! empty( $instance[‘title’] ) ? $instance[‘title’] : $default_title;

    /** This filter is documented in wp-includes/widgets/class-wp-widget-pages.php */
    $title = apply_filters( ‘widget_title’, $title, $instance, $this->id_base );

    echo $args[‘before_widget’];

    if ( $title ) {
    echo $args[‘before_title’] . $title . $args[‘after_title’];
    }

    $format = current_theme_supports( ‘html5’, ‘navigation-widgets’ ) ? ‘html5’ : ‘xhtml’;

    /** This filter is documented in wp-includes/widgets/class-wp-nav-menu-widget.php */
    $format = apply_filters( ‘navigation_widgets_format’, $format );

    if ( ‘html5’ === $format ) {
    // The title may be filtered: Strip out HTML and make sure the aria-label is never empty.
    $title = trim( strip_tags( $title ) );
    $aria_label = $title ? $title : $default_title;
    echo ‘<nav role=”navigation” aria-label=”‘ . esc_attr( $aria_label ) . ‘”>’;
    }
    ?>

    <?php
    if ( ‘html5’ === $format ) {
    echo ‘</nav>’;
    }

    echo $args[‘after_widget’];
    }

    /**
    * Handles updating settings for the current Meta widget instance.
    *
    * @since 2.8.0
    *
    * @param array $new_instance New settings for this instance as input by the user via
    * WP_Widget::form().
    * @param array $old_instance Old settings for this instance.
    * @return array Updated settings to save.
    */
    public function update( $new_instance, $old_instance ) {
    $instance = $old_instance;
    $instance[‘title’] = sanitize_text_field( $new_instance[‘title’] );

    return $instance;
    }

    /**
    * Outputs the settings form for the Meta widget.
    *
    * @since 2.8.0
    *
    * @param array $instance Current settings.
    */
    public function form( $instance ) {
    $instance = wp_parse_args( (array) $instance, array( ‘title’ => ” ) );
    ?>
    <p>
    <label for=”<?php echo $this->get_field_id( ‘title’ ); ?>”><?php _e( ‘Title:’ ); ?></label>
    <input class=”widefat” id=”<?php echo $this->get_field_id( ‘title’ ); ?>” name=”<?php echo $this->get_field_name( ‘title’ ); ?>” type=”text” value=”<?php echo esc_attr( $instance[‘title’] ); ?>” />
    </p>
    <?php
    }

Visualizando 1 resposta (de um total de 1)
  • Olá @stellafernandes , tudo bem?

    Isso é um arquivo padrão do WordPress e não pode ser removido. Você tem mais detalhes do erro? Se sim, posta aqui, por favor.

    Sugiro fazer um backup do seu site (importante!) e tentar atualizar a versão do WordPress. Isso vai fazer com que arquivos padrões, como esse, sejam atualizados.

    Abraços!

Visualizando 1 resposta (de um total de 1)
  • Você deve estar conectado para responder a este tópico.