Suporte » Instalando o WordPress » Erro na página de Login

Visualizando 11 respostas - 1 até 11 (de um total de 11)
  • Samuel, vê se você não tem espaços em branco na primeira e na última linha do wp-config.php. Não pode ter, ou ele vai gerar mesmo o Cannot modify header information. Dá um backspace antes do primeiro <?php. Deve resolver!

    Não tem espaço…
    Tentei hoje enviar os arquivos do WP 2.6.3 exceto o wp-config.php e a pasta /content.

    Mas continua na mesma…
    Ao tentar o login continua o erro e colocando meu username e senha aparece isso:

    Warning: Cannot modify header information – headers already sent by (output started at /home/farmabio/public_html/blog/wp-config.php:1) in /home/farmabio/public_html/blog/wp-login.php on line 267

    Warning: Cannot modify header information – headers already sent by (output started at /home/farmabio/public_html/blog/wp-config.php:1) in /home/farmabio/public_html/blog/wp-login.php on line 279

    Warning: Cannot modify header information – headers already sent by (output started at /home/farmabio/public_html/blog/wp-config.php:1) in /home/farmabio/public_html/blog/wp-includes/pluggable.php on line 595

    Warning: Cannot modify header information – headers already sent by (output started at /home/farmabio/public_html/blog/wp-config.php:1) in /home/farmabio/public_html/blog/wp-includes/pluggable.php on line 596

    Warning: Cannot modify header information – headers already sent by (output started at /home/farmabio/public_html/blog/wp-config.php:1) in /home/farmabio/public_html/blog/wp-includes/pluggable.php on line 597

    Warning: Cannot modify header information – headers already sent by (output started at /home/farmabio/public_html/blog/wp-config.php:1) in /home/farmabio/public_html/blog/wp-includes/pluggable.php on line 770

    Percebi que os Feeds dão erro também. Não estão funcionando…

    Samuel,

    Esse erro realmente é por causa de algum espaço ou caractere estranho no wp-config.php. A mensagem de erro está dizendo que o problema é na linha 1 do arquivo. Isso quer dizer que provavelmente antes de <?php há algum espaço. Abra o arquivo em um editor de textos simples, pode ser Notepad ou BBEdit, para corrigir isso. Aí envie o arquivo novamente para seu servidor, se você corrigir, mas não substituí-lo no servidor não adianta nada. 🙂

    abs.
    Cátia

    Cátia, eu verifiquei o wp-config.php no bloco de notas e enviei novamente para o servidor como Eduardo havia aconselhado, mas continua a mesma coisa. Vejam o arquivo: http://farmabiozero.googlepages.com/*editado*

    Samuel, não publique a senha do seu BD assim, publicamente! Isso é muito perigoso, alguém mal intencionado pode fazer a festa com seu BD munido desses dados… Editei seu link, e peço que você providencie um novo wp-config.php, mas sem nome de usuário, BD e senha.

    Faça o seguinte: baixe o BD através de alguma ferramenta de gerenciamento, como o phpMyAdmin. Em seguida, instale um servidor local (via EasyPHP, por exemplo), e instale uma versão limpa do WordPress localmente. Importe o BD, e veja se o problema persiste.

    Ou então, baixe o WordPress novamente, e reenvie os arquivos para o servidor, substituindo os atuais, inclusive o wp-config.php, mudando, claro, nome de usuário, nome do BD e senha no wp-config.phpnovo.

    []’s!

    Boa idéia. Eu baixei o Arquivo .sql do meu BD e importei pro EasyPHP. Configurei e instalei tudo e finalizei instalando o WordPress com sucesso.
    Masssss… O problema continua da mesma maneira.
    Aí me pergunto: Será que é no BD?

    Tenho uma observação: Quando entro na página de login localmene no wordpress ele me direciona pra versão online [http://farmabio.com.br/blog/wp-login.php?redirect_to=http%3A%2F%2F127.0.0.1%2Fwordpress%2Fwp-admin%2F].
    Quando tento acessar a pasta do wordpress tb me direciona para a versão online.
    Vejam as imagens:
    [1] http://farmabiozero.googlepages.com/1.jpg
    [2] http://farmabiozero.googlepages.com/2.jpg
    [3] http://farmabiozero.googlepages.com/3.jpg

    Será que a quando eu atualizar pelo Fantastico quando estiver disponível a v. 2.7 o problema se resolve?
    Alguém????

    Oi Samuel,

    Provavelmente seu problema é no BD mesmo, Se você é o único user do seu blog, eu aconselho você a:

    1. exportar o conteúdo do seu blog via painel/gerenciar/exportar
    2. desinstalar o WP e instalar de novo uma versão zerada
    3. importar o conteúdo

    E a sua instalação local está apontando prá versão online porque vc puxou todo o bd, tem que mudar a configuração do endereço do seu site para algo do tipo http://localhost/seublog.

    Abs
    Cátia

    Samuel,

    Tive o mesmo problema que voce, agora a pouco, quando fiz o upgrade para o WP 2.7, entrei aqui pra ver se achava uma solução mas, por sorte, resolvi meu problema.

    Experimente o seguinte:

    Abra seu wp-config.php no bloco de notas, ele ja esta editado correto, va em “Salvar como” (Save as), na caixa do “Salvar como” verifique la em baixo em “Codificação” se não esta definida pra “UTF-8”, defina como “ANSI”, salve e substitua no servidor.

    Pra mim funcionou.

    Boa sorte e um abraço.

    consegui com a ajuda do amigo acima

Visualizando 11 respostas - 1 até 11 (de um total de 11)
  • O tópico ‘Erro na página de Login’ está fechado para novas respostas.