Suporte » Ajustando o WordPress » Erro na página de feed

  • Resolvido juliotk

    (@juliotk)


    Oi pessoal,
    estou com um problema que ainda não consegui resolver, com a página de feeds do meu site, quando clico no link, aparece este erro:
    Erro no processamento de XML: declaração xml não está no início da entidade externa
    Posição: http://www.relacionadamente.com.br/?feed=rss2
    Número da linha 15, Coluna 1:<?xml version=”1.0″ encoding=”UTF-8″?>
    ^
    Já olhei em vários fóruns e até no faq, mas não consigo resolver.
    Meu site é:
    http://www.relacionadamente.com.br
    Usando MySql V.4 e PHP V.5
    Grato pela ajuda.
    Júlio Tkac

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • Dei uma verificada no seu feed, e o mesmo não está validando… O validador aponta um erro bizarro, diz que a página em questão não é um feed (?).

    Fez alguma alteração recente no WordPress? Seria uma boa substituir os arquivos originais por outros, baixados diretamente do site oficial, e da mesma versão (detalhe importantíssimo). Talvez resolva.

    Movendo o tópico de Avisos e Dicas Importantes para Sobre o funcionamento e resolução de problemas.

    []’s!

    Criador do tópico juliotk

    (@juliotk)

    Olá,
    resolvi!
    é o seguinte, eu tinha incluído algumas linhas no início da index.php do wordpress, não na index do tema, para fazer funcionar o validador do google adsense e depois de muita ralação, descobri que removendo aquelas linhas do início da index.php e deixando-a original.
    Essas são as linhas que eu inclui e tive que remover para resolver:
    <head>
    <meta name=”verify-v1″ content=”3dArntvvmf/AQGiONlgpnzUt4HGe3EuoUJjGlzpNuaw=” />
    </head>
    Grato pela ajuda de todos.

    Romenum

    (@romenum)

    Oi, pessoal…

    Vi o problema do amigo aí de cima e vi também como ele conseguiu resolvê-lo. Bom, estou exatamente com o mesmo problema!

    XML Parsing Error: xml declaration not at start of external entity
    Location: http://romenum.com/blog/feed
    Line Number 2, Column 1:<?xml version=”1.0″ encoding=”UTF-8″?>

    Reparei também que o Opera me mostra outros dados além desses:

    A interpretação XML falhou: erro de sintaxe (Linha: 2, Caractere: 61)

    Refazer documento como HTML
    Erro:invalid XML declaration
    Especificação:http://www.w3.org/TR/REC-xml/#NT-XMLDecl
    1:
    2: <?xml version=”1.0″ encoding=”‘.get_option(‘blog_charset’).'”?>
    3: <rss version=”2.0″
    4: xmlns:content=”http://purl.org/rss/1.0/modules/content/&#8221;
    5: xmlns:wfw=”http://wellformedweb.org/CommentAPI/&#8221;

    Bom, depois que eu instalei um tema que o suplício começou. O fato é que eu não domino esse lance de sair procurando erros em arquivos php e coisa e tal, até por desconhecimento da linguagem mesmo, entre outros.

    Meu site é http://romenum.com/blog/
    Grato desde já!

    Pessoal, resolvi de uma maneira muito prática e que muitas vezes me peguei sem reparar, verifiquem em Aparência > Temas e simplesmente clique em atualizar tema automaticamente Esperto ter ajudado!

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • O tópico ‘Erro na página de feed’ está fechado para novas respostas.