Suporte » Ajustando o WordPress » erro na index , site nao abre

  • Pessoal boa noite,
    baxei o tema flash, fiz o site todo, quando terminei, vi que tinha um erro na pagina do blog, as miniaturas nao estavam aparecendo, entao resolvido subir novamente os fincheiros principais do tema, pois nao lembrava se tinha mechido em algo.
    e agora ele da este erro:

    Fatal error: Call to undefined function get_header() in /home/vitta481/public_html/index.php on line 16

    alguem pode me dizer qual e a bobagem que eu nao sei oque ta rolando?

    <?php
    /**
    * The main template file.
    *
    * This is the most generic template file in a WordPress theme
    * and one of the two required files for a theme (the other being style.css).
    * It is used to display a page when nothing more specific matches a query.
    * E.g., it puts together the home page when no home.php file exists.
    *
    * @link https://codex.wordpress.org/Template_Hierarchy
    *
    * @package Flash
    */

    get_header(); ?>

    <?php
    /**
    * flash_before_body_content hook
    */
    do_action( ‘flash_before_body_content’ ); ?>

    <div id=”primary” class=”content-area”>
    <main id=”main” class=”site-main” role=”main”>

    <?php
    if ( have_posts() ) :

    if ( is_home() && ! is_front_page() ) : ?>
    <header>
    <h1 class=”page-title screen-reader-text”><?php single_post_title(); ?></h1>
    </header>

    <?php
    endif;

    /* Start the Loop */
    while ( have_posts() ) : the_post();

    /*
    * Include the Post-Format-specific template for the content.
    * If you want to override this in a child theme, then include a file
    * called content-___.php (where ___ is the Post Format name) and that will be used instead.
    */
    get_template_part( ‘template-parts/content’, get_post_format() );

    endwhile;

    the_posts_navigation();

    else :

    get_template_part( ‘template-parts/content’, ‘none’ );

    endif; ?>

    </main><!– #main –>
    </div><!– #primary –>

    <?php
    /**
    * flash_after_body_content hook
    */
    do_action( ‘flash_after_body_content’ ); ?>

    <?php
    get_sidebar();
    get_sidebar(‘left’);
    get_footer();

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 1 resposta (de um total de 1)
  • Moderador Rahmohn

    (@rahmohn)

    Olá, @cremogemahc.

    Acessei o link do site e está funcionando normalmente. Provavelmente você encontrou a solução para o erro que estava ocorrendo. Se sim, compartilhe o que você fez. Dessa forma, outras pessoas podem ser receber ajuda por meio do seu tópico.

Visualizando 1 resposta (de um total de 1)
  • O tópico ‘erro na index , site nao abre’ está fechado para novas respostas.