Suporte » Temas » Erro: menu diferente em posts e em paginas

Visualizando 15 respostas - 1 até 15 (de um total de 15)
  • Aqui: http://www.fashionsubmarine.com/ tem chamadas duplicadas do <head> e de algumas outras tags.. verifique se você não está chamando no seu tema o wp_head() duas vezes, ou algo assim.

    .

    Ou melhor.. parece que o wp_head() está sendo chamado dentro do body. Dê uma verificada, mas parece ser isso.

    .

    Criador do tópico pedro

    (@pfaria)

    fdaciuk, acho que não..
    porque, inclusive, o menu na pagina principal sempre ficou normal, de uma hora pra outra é que resolveu dar esse problema

    se não for pedir demais, que arquivo php eu posso colocar o codigo aqui pra dar uma analisada?

    coloca o teu header.php, a index.php e a página que está chamando o link http://www.fashionsubmarine.com/oblog/

    .

    Criador do tópico pedro

    (@pfaria)

    header:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>>
    <head profile="http://gmpg.org/xfn/11">
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    <title>FASHION SUBMARINE.COM <?php if ( is_single() ) { ?> <?php } ?> <?php wp_title(); ?></title>
    <meta name="generator" content="WordPress <?php bloginfo('version'); ?>" /><!-- leave this for stats -->
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    <link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />
    <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    <?php wp_head(); ?>
    
    <!-- Fade de imagens -->
    <script type="text/javascript" src="http://fashionsubmarine.com/wp-content/themes/neatness/fade/jquery.min.js"></script>
    <script type="text/javascript" src="http://fashionsubmarine.com/wp-content/themes/neatness/fade/fade.js"></script>
    <script src="http://fashionsubmarine.com/wp-content/themes/neatness/fade/jquery.js" type="text/javascript"></script>
    
    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js"></script>
    <script type="text/javascript" src="http://fashionsubmarine.com/wp-content/themes/neatness/slide.js"></script>
    <script type="text/javascript">
    
    var mygallery=new fadeSlideShow({
    
    	wrapperid: "banner", //ID of blank DIV on page to house Slideshow
    	dimensions: [540, 100], //width/height of gallery in pixels. Should reflect dimensions of largest image
    	imagearray: [
    		["http://fashionsubmarine.com/wp-content/themes/neatness/images/banner11.jpg"],
    		["http://fashionsubmarine.com/wp-content/themes/neatness/images/banner22.jpg"]
    	],
    
    	displaymode: {type:'auto', pause:4500, cycles:0, wraparound:false},
    	persist: false, //remember last viewed slide and recall within same session?
    	fadeduration: 1000, //transition duration (milliseconds)
    	descreveal: "ondemand",
    	togglerid: ""
    })
    </script>
    
    </head>
    <body>
    <div id="wrapper"></div>
    <div id="header"></div>
    
    	<div id="menu">
    		<ul>
    			<li><a href="http://www.fashionsubmarine.com/">Home</a></li>
    			<?php wp_list_pages('title_li=' ); ?>
    		</ul>
    	</div>
    	<!-- end menu -->
    
    <div id="page">
    <div id="page-bgtop">
    <div id="page-bgbtm">

    index:

    <?php get_header(); ?>
    
    <div id="content">
    <div id="banner"> </div>
    <br />
    
    	<?php if (have_posts()) :  while (have_posts()) : the_post(); ?>
    
    	<div id="post-<?php the_ID(); ?>" class="post">
    		<h2 class="title"><a href="<?php the_permalink() ?>" rel="bookmark" title="<?php the_title(); ?>">
    			<?php the_title(); ?>
    			</a></h2>
    		<p class="meta"> <?php the_date(); ?> por <?php the_author(); ?>
    			<?php comments_popup_link('Comente!', '1 Comentário', '% Comentários', 'comments'); ?>
    		</p>
    		<div class="entry">
    
    					<?php the_content('Continue lendo...'); ?>
    
             <p class="tags"><?php if (function_exists('the_tags')) { ?> <?php the_tags('Tags: <span class="link"> ', ', ', '</span>'); ?> <?php } ?></p>
    
             <small>
            Pulbicado nas categorias <?php the_category(', ') ?>.<br /><br />
            </small>
    
           <div id="fb-root"></div><script src="http://connect.facebook.net/pt_BR/all.js#appId=220215964688965&xfbml=1"></script><fb:like href="<?php the_permalink(); ?>" send="false" width="539" show_faces="true" font=""></fb:like>
    
            <p class="fimdopost"><?php comments_popup_link('Comente!', '1 Comentário', '% Comentários'); ?></p> 
    
    		</div>
    	</div>
    
    	<?php endwhile; ?>
    	<div class="navigation">
    		<div class="alignleft">
    			<?php previous_posts_link('&laquo; Recentes') ?>
    		</div>
    		<div class="alignright">
    			<?php next_posts_link('Antigos &raquo;') ?>
    		</div>
    	</div>
    	<?php else : ?>
    	<h2 class="center">Not Found</h2>
    	<p class="center">Sorry, but you are looking for something that isn't here.</p>
    	<?php include (TEMPLATEPATH . "/searchform.php"); ?>
    	<?php endif; ?>
    </div>
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    como assim a página que está chamando o link?

    Esse link: http://www.fashionsubmarine.com/oblog/

    Se for uma página, o arquivo é o page.php, se for post, é o post.php, se não tiver nenhuma dessas páginas, está usando o index.php, que você já colocou.

    Daqui a pouco dou uma analisada pra ver se encontro algo.

    .

    Criador do tópico pedro

    (@pfaria)

    page.php:

    <?php get_header(); ?>
    
    <div id="content">
    <div id="banner"> </div><br />
    
    		<?php if (have_posts()) : while (have_posts()) : the_post(); ?>
    
    			<div class="post" id="post-<?php the_ID(); ?>">
    				<h2 class="title"><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title(); ?>"><?php the_title(); ?></a></h2>
    				<div class="entry">
    			<div class="entry-bgtop">
    				<div class="entry-bgbtm">
    					<?php the_content('<p class="serif">Read the rest of this page &raquo;</p>'); ?>
    					<?php wp_link_pages(array('before' => '<p><strong>Pages:</strong> ', 'after' => '</p>', 'next_or_number' => 'number')); ?>
    				</div>
    				</div>
    				</div>
    			</div>
    
    		<?php endwhile; endif; ?>
    
    		<div class="navigation">
    			<?php edit_post_link('Edit this entry.', '<p>', '</p>'); ?>
    		</div>
    	</div>
    
    <?php get_sidebar(); ?>
    
    <?php get_footer(); ?>

    Bom.. parece estar tudo certo.. é difícil analisar sem rodar os códigos.. mas parece que tem alguma coisa empurrando o wrapper 15px para baixo..

    Tenta verificar se não é algum plugin plugin que você está usando.. Desabilite todos e vá habilitando um a um pra ver se resolve o problema. Se você disse que isso aconteceu do nada, pode ser culpa de algum plugin.

    Faça os testes ae e volte a postar se não tiver sucesso que tentaremos uma outra maneira pra resolver, ok?!

    Abraço!

    .

    Criador do tópico pedro

    (@pfaria)

    testes feitos!
    nada resolvido hehehe

    cara, você já viu alguma coisa parecida com isso?

    to impressionado hehehehe

    Pois é.. nunca vi.. Pra poder te ajudar, precisaria ter acesso ao seu admin do WP, mas fica complicado confiar em quem você não conhece né, heheh!!

    O que dá pra você fazer, é tentar fazer essa mesma instalação em um servidor de homologação e me passar o acesso admin pra eu ver se conseguimos resolver isso.

    Veja o que você acha melhor.

    Abraço!

    .

    Criador do tópico pedro

    (@pfaria)

    me passa seu email, fdaciuk?
    pedro@fashionsubmarine.com

    Olá Pedro, te mandei um e-mail.

    Criador do tópico pedro

    (@pfaria)

    respondido!

    Assim que conseguir encontrar a solução definitiva, posta aqui. Pode ser que seja algum problema de plugin ou de algum JS.

    Criador do tópico pedro

    (@pfaria)

    bem, o motivo não sabemos, mas fdaciuk me deu a solução:

    Cara.. seguinte..

    Resolvi temporariamente seu problema =)

    A solução não é das melhores, mas quebra um galho.

    Coloquei uma condicional no header, pra verificar se está na home e tirar aquele espaço que sobra:

    <?php if( is_front_page() || is_single() ) ?>
    	<style type="text/css">
    		body > div#wrapper { margin-top: -15px }
    	</style>
    <?php endif; ?>

    Ainda continuo acreditando que o problema se deve a algum plugin ou algum javascript, que está colocando os dados que eram pra estar dentro de <head> no <body> da página. Isso só acontece na home, nas outras páginas está certinho.

    Verifique os seus arquivos Javascript ou se pode ser de algum plugin o problema. Mas isso que eu fiz resolve, ao menos por enquanto.

Visualizando 15 respostas - 1 até 15 (de um total de 15)
  • O tópico ‘Erro: menu diferente em posts e em paginas’ está fechado para novas respostas.