• Resolvido thauanapessoa

    (@thauanapessoa)


    Bom dia!

    Não estou conseguindo acessar meu site, está aparecendo esse erro
    Fatal error: Arrays are not allowed in class constants in /home/energ124/public_html/wp-content/plugins/jetpack/vendor/automattic/jetpack-sync/src/Modules.php on line 31

    Não consigo nem acessar para poder desinstalar o plugin

    Como proceder?

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 6 respostas - 1 até 6 (de um total de 6)
  • Moderador Felipe Elia

    (@felipeelia)

    Olá!

    Você pode desativar o plugin mudando o nome da pasta (alterando de jetpack para _jetpack, por exemplo), mas neste caso provavelmente você está usando uma versão muito antiga de PHP. Veja com a sua hospedagem se é possível usar o PHP 5.6, no mínimo, assim o problema deve desaparecer.

    Não se esqueça de voltar caso tenha mais alguma dúvida ou, se for o caso, para marcar seu tópico como “resolvido”, beleza?

    Bom dia, Felipe!

    Versão do PHP: 7.2.7
    Onde fica a pasta dos plugins? Desculpe a falta de informação. Sou bem leiga.

    Moderador Felipe Elia

    (@felipeelia)

    Você pode acessar a sua hospedagem através de FTP (peça os dados para a sua hospedagem se ainda não tiver) e ir até a pasta public_html/wp-content/plugins/. Lá estarão todos os seus plugins.

    É estranho dar este erro, porque nesta versão de PHP (7.2.7) já é permitido definir arrays como constantes de classes. Muitas vezes as hospedagens permitem versões de PHP diferentes por pasta. Tente conferir a versão usada na pasta do site (a public_html no seu caso).

    Olá, bom dia. Também não consigo acessar o painel. Aparece este erro: Fatal error: Arrays are not allowed in class constants in /home/impre604/public_html/wp-content/plugins/jetpack/vendor/automattic/jetpack-sync/src/Modules.php on line 31

    A questão é a atualização da versão?

    Moderador Felipe Elia

    (@felipeelia)

    Olá @ramiresrafael,

    Este erro não deveria acontecer em versões do PHP maiores ou iguais ao PHP 5.6. Mesmo que a mensagem de erro seja idêntica ao do tópico, é melhor você criar um outro tópico. Assim a gente tem certeza de ajudar com todas as especificidades que o seu caso pode ter.

    Tente atualizar a versão do PHP da sua hospedagem, se não funcionar tente alterar o nome da pasta do plugin pelo FTP e, se mesmo assim não funcionar, crie um novo tópico, beleza?

    Obrigada pela ajuda. Entrei em contato com a hospedagem e eles atualizaram o PHP com uma versão compatível.

Visualizando 6 respostas - 1 até 6 (de um total de 6)
  • O tópico ‘Erro Fatal’ está fechado para novas respostas.