Suporte » Instalando o WordPress » Erro após atualizaçõa 4.2

  • Resolvido leuhgrimm

    (@leuhgrimm)


    Pessoal, após fazer a atualização do WordPress, em PLUGINS, todos os que estavam para atualizar, aparece a seguinte mensagem no lugar de ATUALIZAR

    Warning: printf(): Argument number must be greater than zero in /home/rosavale/public_html/store/wp-admin/includes/update.php on line 289

    Não estou conseguindo atualizar eles por esse motivo!

Visualizando 15 respostas - 1 até 15 (de um total de 17)
  • Também estou tendo o mesmo problema.

    Tenho vários sites que utilizo o WordPress como CMS e todos estão com o mesmo erro após a atualização para a versão 4.2.

    Boa noite,

    Confirmo que sofro com o mesmo problema. Mas na atualização para a versão 4.2 um dos destaques é “Atualização de plugins agilizada”, com uma suposta novidade que é “Atualizar agora”, onde ao clicar se verá “a mágica funcionar”… (ops WordPress)

    Para atualizar os plugins após atualizar para versão 4.2, estou indo em Painel > Atualizações, seleciono os plugins e clico no botão “Atualizar plugins”.

    Também espero que o WordPress solucione o caso dentro da própria página dos plugins.

    Abraços,

    Galera,

    Após a atualização, também ocorreu esse erro. Eu atualizei os plugins e agora as páginas do site não aparecem. Todas estão com erro 404.

    Mais alguém com esse problema?

    Olá aokitos,

    Erro 404 não ocorreu. Mas você ainda tem acesso ao wp-admin? Se sim, desabilite todos os plugins e verifique se o site volta ao normal. Se voltar, precisa ativar os plugins 1 a 1 para saber qual está causando o erro. Se não voltar, espero que tenha a boa prática de ter backup do site, pois deve ter um backup em versão 4.1, instala ela e aguarda o WordPress lançar 4.2.1, onde devem solucionar o caso, ou entre em contato com o suporte do plugin alertando para o problema que eles devem lançar uma atualização.

    Abraços,

    Também estou como o mesmo problema, em vários sites.

    Estou fazendo atualização manual dos plugins, via FTP, para contornar o problema.

    Abraços.

    Bom dia gurudasmaquinas e demais,

    Com a atualização 4.2.2 começou a funcionar em meus sites a instalação 1 click, sugiro que verifiquem.

    Abraços,

    Todos meus sites ainda continuam com o mesmo problema, mesmo com a versão 4.2.2.

    Gente, tenho o mesmo problema com essas atualizações caso alguém tenha uma solução avisem por favor, grato.

    Atualizei os plugins e funcionou normal.

    Sobre o erro 404 citado acima, tive um problema parecido, só modifiquei a permissão para 777 a pasta em questão.

    Pessoal, para atualizar sem precisar enviar os arquivos via FTP, da para marcar (checkbox) cada um que você quer atualizar (Pois tenho uns que não estão testados para 4.2.2 ) e ir na lista (dropbox) e selecionar Atualizar e depois clicar no Botão Aplicar.
    Não resolve o erro, mas atualiza os plugins.

    Moderador Miriam de Paula

    (@miriamdepaula)

    Infelizmente este problema ainda não foi solucionado. Mas a dica do Vinycps é válida para uma ação temporária.

    Pessoal,

    O erro está na versão oficial do wordpress.

    Para corrigir temporariamente enquanto eles não o fazem, faça o seguinte:

    Vão na pasta
    /wp-admin/includes

    Abra o arquivo update.php

    altere a linha 289 disso aqui:

    printf( __( 'There is a new version of %1$s available. <a href="%2$s" title="%3$s">View version %4$s details</a> or <a href="%5$s">update now</a>.' ), $plugin_name, esc_url( $details_url ), esc_attr( $plugin_name ), $r->new_version, wp_nonce_url( self_admin_url( 'update.php?action=upgrade-plugin&plugin=' ) . $file, 'upgrade-plugin_' . $file ) );

    para isso aqui:

    printf( __( 'There is a new version of %1$s available. <a href="%2$s" title="%3$s">View version %4$s details</a>.' ), $plugin_name, esc_url( $details_url ), esc_attr( $plugin_name ), $r->new_version, wp_nonce_url( self_admin_url( 'update.php?action=upgrade-plugin&plugin=' ) . $file, 'upgrade-plugin_' . $file ) );

    Salvem o arquivo e testem a página de plugins que vai voltar a funcionar

    Abs

    Moderador Miriam de Paula

    (@miriamdepaula)

    Junior! Você mesmo poderia contribuir e muito para a solução deste problema, já que você o identificou e sabe como corrigir. Basta entrar em contato com o pessoal de desenvolvimento do WordPress!!! Contribua, não espere que façam! Faça você! O WordPress é um sistema de código aberto e todos podemos ajudar no seu desenvolvimento 🙂

    Bug Reports

    Leonardo

    (@lmsbiomedical)

    Obrigado Junior Grao!!! Funcionou perfeitamente!

    Gênio! Estava com o mesmo problema!
    E agora está funcionando perfeitamente.

    Obrigado Mr. Junior!

Visualizando 15 respostas - 1 até 15 (de um total de 17)
  • O tópico ‘Erro após atualizaçõa 4.2’ está fechado para novas respostas.