Suporte » Ajustando o WordPress » Erro ao criar e editar Post

  • Ao criar e editar post no blog esta dando erro do Plugin Elementor, se alguém puder me ajudar agradeço, WordPress 5.2.2 com o tema Virtue. Segue erro:

    Fatal error: Uncaught TypeError: Argument 2 passed to Elementor\TemplateLibrary\Source_Local::post_row_actions() must be an instance of WP_Post, null given, called in /home/jfmarketingdigit/public_html/wp-includes/class-wp-hook.php on line 286 and defined in /home/jfmarketingdigit/public_html/wp-content/plugins/elementor/includes/template-library/sources/local.php:860 Stack trace: #0 /home/jfmarketingdigit/public_html/wp-includes/class-wp-hook.php(286): Elementor\TemplateLibrary\Source_Local->post_row_actions(Array, NULL) #1 /home/jfmarketingdigit/public_html/wp-includes/plugin.php(208): WP_Hook->apply_filters(Array, Array) #2 /home/jfmarketingdigit/public_html/wp-admin/includes/class-wp-posts-list-table.php(1437): apply_filters(‘post_row_action…’, Array, NULL) #3 /home/jfmarketingdigit/public_html/wp-admin/includes/class-wp-posts-list-table.php(950): WP_Posts_List_Table->handle_row_actions(NULL, ‘title’, ‘title’) #4 /home/jfmarketingdigit/public_html/wp-admin/includes/class-wp-list-table.php(1323): WP_Posts_List_Table- in /home/jfmarketingdigit/public_html/wp-content/plugins/elementor/includes/template-library/sources/local.php on line 860

    O site está passando por dificuldades técnicas. Verifique a caixa de entrada do e-mail do administrador do site para obter instruções.

    • Este tópico foi modificado 1 mês, 3 semanas atrás por  Ralden Souza.
Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • Olá, @francisconetolg!

    Pesquisando sobre a possibilidade de erros parecidos com o que ocorre no teu site, não consegui encontrar nenhuma ocorrência. Nem nos fóruns de suporte do Tema e do Plugin.

    Pelo log do erro, algum dado do post está faltando ou não está sendo entregue. Por isso, retorna o erro e o post não é gravado ou editado.

    O Tema e o Plugin foram atualizados recentemente. Caso ainda não tenha feito, atualize-os e tente novamente.

    Caso isso ainda não resolva o problema, tente desabilitar todos os plugins, menos o Elementor, e tente novamente. Repita o procedimento habilitando um a um, até que possivelmente encontre qual deles está causando essa incompatibilidade. Tente ainda alterar o Tema para o Twenty Nineteen.

    Recebi dia desses a mensagem sobre o site passar por dificuldades técnicas de um cliente. O log de erro informava que o plugin AMP estaria causando o problema e o site era derrubado. Percebi que o problema era incompatibilidade do AMP com o plugin Smuth. O desabilitei e o site voltou ao normal.

    Caso os procedimentos resolvam, por favor, compartilhe conosco para que outras pessoas com o mesmo problema possam encontrar ajuda.

    Olá @rodineicosta

    Já atualizei o Plugin Elementor e o WordPress, desabilitei todos os plugins menos o Elementor e o erro persisti, inclusive desabilitei somente o Elementor e não resolveu tb, tenho outro site com os mesmos Plugins e Tema e não tem este erro, ele começou quando fiz a migração do site para outro servidor, obrigado pelas dicas, vou continuar buscando uma solução, abraço.

    Olá @rodineicosta

    Acabei de fazer um outro teste desabilitei todos os Plugins e deu este erro ao criar um Post:

    Warning: Creating default object from empty value in /home/jfmarketingdigit/public_html/wp-admin/includes/post.php on line 708

    Já tentou verificar no fórum do Plugin Elementor se há alguma ocorrência parecida com possíveis soluções?

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • Você deve estar conectado para responder a este tópico.