Suporte » Ajustando o WordPress » Erro ao adicionar usuários na Versão WordPress 3.1/pt_BR

  • Resolvido fabricio.silvasantos

    (@fabriciosilvasantos)


    Utilizo o WordPress 3.1/pt_BR com a configuração para administrar Multisites. Após atualizar para a versão 3.1 estou tendo problemas para adicionar usuários, aparece o seguinte erro:

    Warning: sprintf() [function.sprintf]: Argument number must be greater than zero in /var/lib/httpd/htdocs/…/portal/wp-admin/user-new.php on line 29

    Warning: Cannot modify header information – headers already sent by (output started at /var/lib/httpd/htdocs/uenf/portal/wp-admin/user-new.php:29) in /var/lib/httpd/htdocs/…/portal/wp-includes/pluggable.php on line 897

    Alguém sabe qual o problema ?

Visualizando 6 respostas - 1 até 6 (de um total de 6)
  • Vc alterou o arquivo user-new.php de alguma forma ou pelo menos chegou a abri-lo em algum editor?

    Pergunto isso porque o erro Cannot modify header é gerado com espaços em branco no início dos arquivos e muitas vezes gerados por caracteres inseridos devido a assinatura unicode bom

    Aqui neste site tem uma explicação disso e como resolver a assinatura unicode bom http://alessandrosantos.com.br/2008/10/28/problemas-com-a-codificacao-utf-8-em-php/

    Nada, eu apenas atualizei o WordPress para a versão 3.1 / pt_BR.

    Pode ter alguma relação com a versão do PHP ou alguma configuração no servidor ?

    Tem acontecido muitos erros com servidores windows, para o wordpress o recomendado é linux.

    Tente pegar este arquivo do seu pc e envia-lo novamente via ftp para o servidor substituindo o que está no servidor.

    Talvez o arquivo não tenha sido copiado corretamente na atualização anterior, principalmente se vc realizou uma atualização automática pelo sistema.

    Isso é outra coisa que está só gerando problemas.

    Olá:

    Estava com o mesmo problema e meu caso é o mesmo, eu uso o multisites. Resolvi apagando a variável que a função admin_created_user_email recebe por parâmetro no wp-admin/user-new.php. Ficou assim: function admin_created_user_email() {.

    Eu estou com esse problema também… @boogerboy eu fiz a sua recomendação mas o problema persiste… você poderia explicar um pouco mais o que fez, por favor?
    abr

    Pessoal,

    Esse erro acontecia devido a problema na tradução para o português do Brasil que já foi corrigido. Se alguém ainda tiver esse problema, basta pegar o arquivo mais novo da tradução (em wp-brasil.org você acha ele)

    Leo,,

Visualizando 6 respostas - 1 até 6 (de um total de 6)
  • O tópico ‘Erro ao adicionar usuários na Versão WordPress 3.1/pt_BR’ está fechado para novas respostas.