Suporte » Ajustando o WordPress » envio de formulários – wp 4.6.1

  • Resolvido rnd4web

    (@rnd4web)


    Pessoal,

    Tenho uma instalação WP com um tema instalado e funcionando perfeitamente, mas não consigo enviar nenhum formulário.

    Já tentei diversas formas – até mesmo instalar uma API do Google para disparo via SMTP – essa última opção, se mostra configurada com sucesso, mas quando do envio dos formulários nunca se completa – sempre retorna mensagem de erro.

    Minha hospedagem é Locaweb.

    Tentei a instalação/configuração em outro domínio (independente deste que apresenta esse erro) e também não consegui sucesso. O que essas duas instalações tem em comum: ambas são 4.6.1 e estão na LKocaweb.

    Seria esse o grande mal?

Visualizando 3 respostas - 1 até 3 (de um total de 3)
  • Moderador Felipe Elia

    (@felipeelia)

    Oi @rnd4web,

    Seria esse o grande mal?

    SIM! hahaha

    Tente instalar o plugin WP Mail SMTP e configurá-lo de forma que todos os e-mails sejam mandados através dele. Se você precisar usar um e-mail do gmail é um pouco mais complicado, você vai precisar de outro plugin, criar um app no google e etc., mas antes de partir para essa solução é mais fácil tentar o plugin que indiquei com uma conta de SMTP de um e-mail da própria Locaweb.

    Não esqueça de voltar aqui e contar como progrediu no problema, ok? Se resolver não esqueça de marcar seu tópico como “resolvido”. Boa sorte!

    Oi @felipeelia,

    Vamos lá, já tentei muitos plugins – aliás o meu preferido é esse mesmo, o WP Mail SMTP – mas ele se mostra como não verificado para essa versão do WP 4.6.1 – mas mesmo assim tentei com ele também. Nada deu certo até o momento.

    Quanto a API no google, até isso eu já fiz – achei um tutorial de uma gringa explicando tudo certinho – inclusive, a API de SMTP se mostra como ativa no site – fiquei mega feliz depois que ela se mostrou ativa, achando que tudo estava resolvido – alegria de principiante rs

    A Locaweb indicou mudar a versão do php da minha instalação – que atualmente está na 5.6

    Veja a indicação da locaweb no descritivo abaixo:

    Para ajustar o problema realizamos a alteração do php para 5.5 bem como alteramos o host de smtp para “ssl://smtp.gmail.com”, a alteração da versão do php
    foi realizada devido a incompatibilidade da class phpmailer utilizada pelo plugin com o php 5.6 e 7, desta forma existem duas opções:

    – Entrar em contato com o desenvolvedor do plugin e passar tal informação solicitando que utilize a class phpmailer :https://github.com/PHPMailer/PHPMailer uma vez que tal versão
    do link é funcional em todas as versões do php na locawbe.

    – Alterar a versão do php para 5.5 ou inferior:http://wiki.locaweb.com.br/pt-br/Como_alterar_a_vers%C3%A3o_do_PHP

    Estou aguardando eles realizarem a migração da versão do php. Novidades aviso todos aqui.

    Saudações pessoal,

    Problema resolvido depois do downgrade para PHP 5.5
    Também foi configurado – conforme descrito acima, o host smtp para: ssl://smtp.gmail.com

    Ficou a lição. Agradeço ao @felipeelia pela atenção e preocupação.

    Vou encerrar o tópico.

Visualizando 3 respostas - 1 até 3 (de um total de 3)
  • O tópico ‘envio de formulários – wp 4.6.1’ está fechado para novas respostas.