Suporte » Plugins » Elementor – Uncaught Error: Too few arguments to function

  • Salve, amigos! Tudo bem?

    Sou iniciante em desenvolvimento WordPress, mas já estou “no corre” porque tenho 2 bocas pra alimentar.

    Fui contratado para customizar o site de um cliente que usava, até então, o tema “WPStore Pro”.

    Fui contratado para customizar o site no tema Marketo.

    Ao fazer o “Header” utilizando o Elementor Pro, depois de tudo configurado e, aparentemente, funcionando no “Preview”, ao atualizar a página dá o seguinte erro, que, por ser mais “complexo”, digamos assim, não estou seguro de como resolver:

    Fatal error: Uncaught Error: Too few arguments to function ElementorPro\Modules\NavMenu\Widgets\Nav_Menu::handle_link_classes(), 3 passed in /home/atacado/atacado.lovelifeatacado.com/wp-includes/class-wp-hook.php on line 287 and exactly 4 expected
    in /home/atacado/atacado.lovelifeatacado.com/wp-content/plugins/elementor-pro/modules/nav-menu/widgets/nav-menu.php on line 1140

    Call stack:

    ElementorPro\M\N\W\Nav_Menu::handle_link_classes()
    wp-includes/class-wp-hook.php:287
    WP_Hook::apply_filters()
    wp-includes/plugin.php:206
    apply_filters()
    wp-content/plugins/ed-megamenu/inc/frontend/EdMegamenuFrontendWalker_class.php:81
    EdMegamenuFrontendWalker::start_el()
    wp-includes/class-wp-walker.php:144
    Walker::display_element()
    wp-content/plugins/ed-megamenu/inc/frontend/EdMegamenuFrontendWalker_class.php:195
    EdMegamenuFrontendWalker::display_element()
    wp-includes/class-wp-walker.php:244
    Walker::walk()
    wp-includes/nav-menu-template.php:608
    walk_nav_menu_tree()
    wp-includes/nav-menu-template.php:228
    wp_nav_menu()
    wp-content/plugins/elementor-pro/modules/nav-menu/widgets/nav-menu.php:1079
    ElementorPro\M\N\W\Nav_Menu::render()
    wp-content/plugins/elementor/includes/base/widget-base.php:530
    Elementor\Widget_Base::render_content()
    wp-content/plugins/elementor/includes/base/widget-base.php:660
    Elementor\Widget_Base::_print_content()
    wp-content/plugins/elementor/includes/base/element-base.php:644
    Elementor\Element_Base::print_element()
    wp-content/plugins/elementor/includes/base/element-base.php:864
    Elementor\Element_Base::_print_content()
    wp-content/plugins/elementor/includes/base/element-base.php:644
    Elementor\Element_Base::print_element()
    wp-content/plugins/elementor/includes/base/element-base.php:864
    Elementor\Element_Base::_print_content()
    wp-content/plugins/elementor/includes/base/element-base.php:644
    Elementor\Element_Base::print_element()
    wp-content/plugins/elementor/core/base/document.php:1224
    Elementor\C\B\Document::print_elements()
    wp-content/plugins/elementor/core/base/document.php:861
    Elementor\C\B\Document::print_elements_with_wrapper()
    wp-content/plugins/elementor/includes/frontend.php:971
    Elementor\Frontend::get_builder_content()
    wp-content/plugins/elementor/includes/frontend.php:889
    Elementor\Frontend::apply_builder_in_content()
    wp-includes/class-wp-hook.php:287
    WP_Hook::apply_filters()
    wp-includes/plugin.php:206
    apply_filters()
    wp-includes/post-template.php:253
    the_content()
    wp-content/plugins/elementor/modules/page-templates/module.php:183
    Elementor\M\P\Module::print_callback()
    call_user_func()
    wp-content/plugins/elementor/modules/page-templates/module.php:200
    Elementor\M\P\Module::print_content()
    wp-content/plugins/elementor/modules/page-templates/templates/canvas.php:36
    include()
    wp-includes/template-loader.php:106
    require_once()
    wp-blog-header.php:19
    require()
    index.php:17

    Podem me ajudar a solucionar esse problema, por favor?

    Desde já, muito obrigado.

    A página que eu preciso de ajuda: [fazer login para ver o link]

  • Você deve estar conectado para responder a este tópico.