Suporte » Ajustando o WordPress » Editor Visual não funciona

  • Resolvido Bruno Riggs

    (@riggsba)


    Quando o editor visual deixa de funcionar em postagens, páginas, etc., o que pode ser? Está configurado no Usuário para mostrar.

Visualizando 6 respostas - 1 até 6 (de um total de 6)
  • Moderador Felipe Elia

    (@felipeelia)

    Oi @riggsba,

    Ele já funcionou e parou de funcionar? Você atualizou alguma coisa?

    Normalmente isto indica um erro de javascript. No seu navegador procure por ferramentas de desenvolvimento e, nele, por uma aba chamada “Console”. No Google Chrome ela aparece ao apertarmos ctrl+shift+i. Se houver algum erro e você não souber o que fazer, volte aqui e diga qual é para que o pessoal possa dar uma olhada para você.

    Só não esqueça de voltar, seja para dizer o erro ou para dizer se resolveu de alguma outra forma. Neste caso, não deixe de marcar seu tópico como resolvido.

    @felipeelia Para te dizer a verdade solicitaram minha ajuda nesse projeto, então não sei se alguma vez já funcionou, sei que o site é multi site e não sei se isso impacta em algo acredito que não deveria, pois tenho outros sites multi site e não ocorre isso.

    Veja que coisa, por desencargo antes de te responder aqui eu fui ver se na rede o editor aparecia e para minha surpresa sim, apenas nos sub sites (digamos assim) dava esse erro. Por curiosidade fui e desabilitei o QTRANSLATE PLUS e fui na postagem, mudei de “editor” para “visual” e os botões voltaram ao normal, o editor funcionou (achei louco), salvei então essa postagem com o a opção “visual” marcada, voltei e ativei o qTranslate Plus e depois fui novamente nas postagens, cara o editor está funcionando, que doideira isso.

    O erro no console era esse:

    JQMIGRATE: Migrate is installed, version 1.4.1
    jquery-migrate.min.js:2:542

    Deprecated TinyMCE API call: <target>.onPostRender.add(..)
    plugin.min.js:1:76

    TypeError: a is null
    [Learn More]
    jquery.js:4:25126

    Moderador Felipe Elia

    (@felipeelia)

    haha que bom que funcionou, @riggsba! Vou marcar o tópico como resolvido. Obrigado por compartilhar a solução 🙂

    Olá Felipe, bom dia.

    No meu WP está acontecendo o mesmo _depois de atualizar para 9.4 (automaticamente) não consigo editar mais nada, nem no visual, nem no HTML. Por favor, preciso de ajuda!
    Fiz o que você sugeriu e apareceu isso:

    https://pastebin.com/zNTtKH2F

    • Esta resposta foi modificada 1 ano, 8 meses atrás por  Felipe Elia. Razão: Código no pastebin
    Moderador Felipe Elia

    (@felipeelia)

    Oi @hotelfazendao,

    Algum plugin ou seu tema está usando uma expressão que o jQuery não está reconhecendo (Uncaught Error: Syntax error, unrecognized expression: a[rel=]).

    Sugiro que você instale e ative o plugin Diagnóstico e, no seu Painel, vá em Health Check, no submenu de Painel mesmo. Na tela que abre vá em Troubleshooting, marque o check e habilite o modo de resolução de problemas. Dessa forma é possível que você desabilite todos os plugins e use um tema padrão do WordPress, para ver qual deles é o responsável pelo erro.

    Este modo do plugin só altera a visualização do site para você, os outros usuários do seu site verão o site do modo normal.

    Se você não conseguir resolver dessa forma, recomendo que você abra um novo tópico, dessa forma seu problema terá mais visibilidade.

    Estou com o mesmo problema que o @hotelfazendao e instalei o plugin de diagnósticos e mesmo com todos os plugins desabilitados o meu editor do wordpress não funciona, tenho que editar em html, se não, não funciona e tudo que escrevo no modo de “visual” se perde quando atualizo.

    • Esta resposta foi modificada 1 ano, 4 meses atrás por  eliascoutinho.
Visualizando 6 respostas - 1 até 6 (de um total de 6)
  • O tópico ‘Editor Visual não funciona’ está fechado para novas respostas.