Suporte » Ajustando o WordPress » Editor Gutenberg não salva postagens

  • Olá amigos
    Recentemente atualizei o site para a última versão do WordPress, mas continuo tendo que usar o editor clássico, já que o Gutenberg não atualiza nem deixa visualizar as postagens.
    Estou com tudo atualizado: WordPress 5.2, PHP 7.3, DB 10, tema, plugins. Ao acessar a nova ferramenta de diagnóstico, ela me mostra o seguinte problema:

    A API REST encontrou um erro
    A API REST é uma forma como o WordPress, e outras aplicações, se comunicam com o servidor. Um exemplo é a tela do editor de blocos, que depende da API para exibir e salvar seus posts e páginas.

    A solicitação à API REST falhou devido ao seguinte erro.
    Erro: [] cURL error 28: Operation timed out after 10000 milliseconds with 0 bytes received

    Como resolver? Obrigado!

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • saudações @barenco,

    pelo que pesquisei no Google sobre esse erro, está relacionado com o servidor. especialmente questões de segurança, firewall. inclusive o erro diz isso…

    sugiro que abra um chamado de suporte com a empresa que hospeda seu WordPress. em vários casos dos que eu vi, é um bloqueio de servidor para com IP de onde está se tentando a conexão. e era indicado usar o plugin abaixo,

    https://br.wordpress.org/plugins/query-monitor/

    ele pode informações mais precisas sobre o erro. o que útil até para passar para a equipe de suporte da empresa de hospedagem.

    espero que essas informações possam ajudar.

    Gassho (mãos em prece), Namaste (eu lhe saúdo)

    Barenco

    (@barenco)

    Olá Ralden
    Obrigado por suas ótimas dicas. Instalei o plugin indicado, mas como não sou ‘aquele especialista’, não identifiquei nada de errado. Nosso site passa por um serviço de CDN que possui um firewall. Então a primeira coisa que fiz foi desabilitar isso. Mas o problema continua.
    Agora abri um chamado em meu provedor de hospedagem. Vamos ver o que eles dizem.
    Abração!

    saudações @barenco,

    se o Query Monitor não disparou um alerta (e é bem visível o alerta dele na barra no topo do WordPress), isso só reforça minha tese de que é uma questão com servidor bloqueando comunicação.

    aguardar o que o suporte da hospedagem diz.

    abraços!

    Barenco

    (@barenco)

    Olá Ralden

    Veja se essa mensagem do depurador do Chrome faz algum sentido para você:

    api-fetch.min.js?ver=3.1.2:1 Mixed Content: The page at ‘https://www.maxicar.com.br/wp-admin/post.php?post=80747&action=edit’ was loaded over HTTPS, but requested an insecure resource ‘http://www.maxicar.com.br/wp-json/wp/v2/posts/80747?_locale=user’. This request has been blocked; the content must be served over HTTPS.

    Usamos o SSL do Let’s Script.

    A mensagem só aparece quanto tentamos salvar a postagem pelo Gutenberg. Com o editor clássico não.

    Barenco

    (@barenco)

    Detalhe: o endereço do site nas Configurações Gerais do WordPress continuam http.

    Barenco

    (@barenco)

    Olá Ralden
    Consegui finalmente descobrir o problema. Há alguns meses instalamos o Certificado SSL, mas a instalação do WordPress ainda fazia referencia ao site como http. No WP antigo não houve problema, mas o 5.2 acusou o conflito de endereços. Alterei o WP-Config mudando para https e tudo funcionou.
    Obrigado!

    saudações @barenco,

    que otima notícia!!! eu ia sugerir o Simple SSL diante do erro, mas que bom que foi mais fácil ainda.

    muito boa sorte com seu WordPress!

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • Você deve estar conectado para responder a este tópico.