Suporte » Ajustando o WordPress » Cópia de site local com direcionamento automático para web

  • Resolvido gerlucio97

    (@gerlucio97)


    boa noite, estou tentando criar uma cópia local desse site no me computador, baixei o banco de dados via phpmyadmin e instalei ele na máquina local, e os arquivos do wordpress via ftp, mas da erro ao conectar com banco de dados mesmo já tendo alterado no wp-config então li em umas páginas de suporte que posso restaurar usando apenas o bando de dados ( o que é bom por que atualizaria o wordpress, antes estava no 4.2.2), fiz a cópia dos arquivos do wordpress manualmente para a instalação e fiz normalmente, leu o banco de dados normal, aí chego na parte de instalação em si do wordpress quando clico em iniciar ele diz que já está instalado (na máquina) e me direciona para o site na web, mesmo digitando no navegador “localhost/o nome que dei para o site (que pode ser qualquer um que dá no mesmo)/wp-admin”, como visitante ainda.

    tem alguma configuração que deixei passar?

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 15 respostas - 1 até 15 (de um total de 19)
  • Moderador Felipe Santos

    (@felipeloureirosantos)

    Olá, tudo bem?

    Para fazer uma migração não basta apenas alterar o URL no wp-config.php.

    Você precisaria renomear todos os links do site antigo para o novo dentro do banco de dados.

    Você pode fazer isso manualmente: https://codex.wordpress.org/pt-br:Mudando_o_URL_do_Site

    Contudo, recomendo que utilize um plugin como o Duplicator, neste caso você apenas irá baixar esses dois arquivos que o plugin irá fornecer quando você criar o “package” e colocar no seu diretório principal do site.

    Em seguida crie o banco de dados, usuário e senha. Depois acesse o arquivo installer.php, e apenas siga os passos apresentados na tela do plugin e o mesmo irá realizar todo procedimento para você.

    Boa noite Felipe, consegui fazer uma cópia local (mas ao mesmo tempo não)

    Fiz assim:
    1 deletei tudo que tinha feito antes para começar do zero, menos o banco de dados.
    2 no banco de dados segui tudo o que estava no artigo sugerido no método “mudando a url diretamente pelo banco de dados.”
    3 copiei os arquivos do wordpress diretamente para dentro do localhost como tinha feito antes, e acessei pelo localhost/(nomedosite)/wp-admin.

    Funcionou perfeitamente, liguei ele ao banco de dados, fui direcionado à tela de instalação do wordpress que me informou que já estava instalado (exatamente como esperava) e fui direcionado para a tela de login, fiz login e quando fui entrar no painel deu erro 404.

    Então fui no endereço no localhost como visitante e a página aparece (meio desconfigurada por que falta instalar os temas e plugins) com uma mensagem no meio como conteúdo ou título da página dizendo que a página não foi encontrada (acho que a 404 do site se funcionasse normal), aí quando eu tento ir por lá mesmo editar tema ou acessar de alguma forma o painel, aparece a mensagem de 404.

    Tenho que configurar o wp-admin? o que faço?

    Ps. não consigo acessar a versão online do site para poder utilizar algum plugin duplicator.

    Atualização, resolvi seguir os passos de alterar pelo wp-config e o funcions.php e não resolveu nada, restaurei as versões dos arquivos anteriores a essa tentativa.

    PS. no erro ao acessar o painel percebi que o link fica assim: http://localhost/nomedosite/localhost/nomedosite/wp-admin/
    quando o que eu digito é
    http://localhost/nomedosite/wp-admin

    Atualizando de novo.

    Consegui resolver uma parte do problema.

    eu copiei a pasta original do site (que baixei por ftp) direto no localhost com um nome diferente como se fosse outro site) e atualizei o wp-config para o mesmo banco de dados desse, e tentei fazer a instalação normal pelo localhost/nomedositenovo/wp-config e já foi pedindo a senha de login, forneci e ele pediu para atualizar o banco de dados, atualizei e cliquei em “pronto!” então fui direcionado para o painel do localdost/nomedositeantigo, mas quando clico em ver site permanece na página 404 como home, e não aparece nenhum plugin nem por exemplo os produtos cadastrados.

    o localhost/nomedositenovo agora direciona para o site antigo (o original desse post)

    Moderador Felipe Santos

    (@felipeloureirosantos)

    Olá, gostaria de entender mais sobre isso.

    Você apenas tem um backup do seu banco de dados de um site que funcionava em http://plascouro.com.br, certo?

    Neste caso, considerando que você mencionou que ainda tem acesso ao site, recomendo que você mova para outro diretório o que tem no ar, e crie um site novo no servidor. Depois suba o seu banco de dados e atualize o seu arquivo wp-config.php com as configurações do banco de dados.

    Considerando o URL estará correto, você conseguirá fazer o que instrui com o Duplicator, e acredito que isso resolverá o seu problema.

    Olá, eu tenho o backup do banco de dados, e a cópia dos arquivos do wordpress que consegui por ftp.

    Deixa eu ver se entendi, é para eu fazer uma reinstalação do wordpress apenas com o banco de dados só que com o site no ar?

    Atualização,
    1 fui testar algumas coisas no site e percebi que não importou os produtos que tinha cadastrado no site, então deletei tudo e comecei uma instalação nova, agora apenas com os arquivos que peguei por ftp e o banco de dados (se deu certo antes deveria dar certo agora) segui exatamente os mesmos passos da instalação anterior mudar o wp-admin, o funcions, e o wp-options no phpmyadmin, deu meio certo, o erro que deu foi esse:

    “Fatal error: Uncaught Error: Call to undefined function wp_add_inline_script() in C:\xampp\htdocs\plascouro\wp-content\themes\i-excel\inc\kirki\modules\webfonts\class-kirki-modules-webfonts-async.php:139 Stack trace: #0 C:\xampp\htdocs\plascouro\wp-includes\plugin.php(496): Kirki_Modules_Webfonts_Async->webfont_loader_script(”) #1 C:\xampp\htdocs\plascouro\wp-includes\general-template.php(2206): do_action(‘wp_head’) #2 C:\xampp\htdocs\plascouro\wp-content\themes\i-excel\header.php(147): wp_head() #3 C:\xampp\htdocs\plascouro\wp-includes\template.php(501): require_once(‘C:\\xampp\\htdocs…’) #4 C:\xampp\htdocs\plascouro\wp-includes\template.php(477): load_template(‘C:\\xampp\\htdocs…’, true) #5 C:\xampp\htdocs\plascouro\wp-includes\general-template.php(45): locate_template(Array, true) #6 C:\xampp\htdocs\plascouro\wp-content\themes\i-excel\404.php(17): get_header() #7 C:\xampp\htdocs\plascouro\wp-includes\template-loader.php(74): include(‘C:\\xampp\\htdocs…’) #8 C:\xampp\htdocs\plascouro\wp-blog-header.php(16): requi in C:\xampp\htdocs\plascouro\wp-content\themes\i-excel\inc\kirki\modules\webfonts\class-kirki-modules-webfonts-async.php on line 139″

    o erro também ocorre como plugin tewntynineteen.

    2 não tenho acesso direto ao painel do site, só a phpmyadmin e ao ftp.

    Moderador Felipe Santos

    (@felipeloureirosantos)

    Olá, tudo bem?

    Você está utilizando a versão mais recente?

    É para instalar o banco de dados que você baixou anteriormente.

    Você fez alguma modificação neste banco de dados?

    Moderador Felipe Santos

    (@felipeloureirosantos)

    Tente seguir está linha:

    1. Instale normalmente o WordPress no seu site;

    2. Faça a instalação de 5 minutos do WordPress;

    3. Insira o banco de dados no servidor;

    4. Altere o wp-config.php para os dados de acesso ao banco de dados que você subiu.

    Boa noite, mas eu estou fazendo isso(instalando a versão mais recente, e tentei instalando/copiando os arquivos diretamente versão 4.2.2.se eu instalo da forma como você orientou ele não carrega os produtos que estão cadastrados.

    Moderador Felipe Santos

    (@felipeloureirosantos)

    Olá, tudo bem?

    Utilize a versão 4.2 mais recente.

    Aqui você encontra todas as versões: https://br.wordpress.org/download/releases/

    Olá Felipe! Obrigado, vou testar e retorno com mais atualizações!

    Boa tarde Felipe!
    Voltando com atualizações.

    Baixei a versão 4.2.23, instalei no localhost (copiei a pasta descompactada no local onde ficam “hospedados” os sites, os outros que tenho instalei assim) e acessei o localhost/…/wp-admin, apareceu atela de conexão do banco de dados, foi normal, pediu pra instalar normal, e depois de clicar no botão de instalar ele me informou que já estava instalado, e pede pra fazer login, até aí tudo normal, mas quando clico no botão de login me retorna esse erro:

    Warning: Illegal string offset ‘remember’ in C:\xampp\htdocs\plscouro\wp-includes\user.php on line 39

    Warning: Cannot assign an empty string to a string offset in C:\xampp\htdocs\plscouro\wp-includes\user.php on line 39

    Warning: Illegal string offset ‘user_login’ in C:\xampp\htdocs\plscouro\wp-includes\user.php on line 54

    Fatal error: Uncaught Error: Cannot create references to/from string offsets in C:\xampp\htdocs\plscouro\wp-includes\user.php:54 Stack trace: #0 C:\xampp\htdocs\plscouro\wp-login.php(795): wp_signon(”, ”) #1 {main} thrown in C:\xampp\htdocs\plscouro\wp-includes\user.php on line 54

    Moderador Felipe Santos

    (@felipeloureirosantos)

    Então, mas não era para fazer isso no localhost. Porque o URL no seu banco de dados está o do seu site, e só vai funcionar se alterar manualmente (não recomendo) ou instalar no URL que utiliza antes.

    1. Instale normalmente o WordPress 4.2.23 no seu site;

    2. Faça a instalação de 5 minutos do WordPress (se o WordPress pedir para atualizar, não atualize!);

    3. Insira o banco de dados no servidor do site;

    4. Altere o wp-config.php para os dados de acesso ao banco de dados que você subiu.

Visualizando 15 respostas - 1 até 15 (de um total de 19)
  • O tópico ‘Cópia de site local com direcionamento automático para web’ está fechado para novas respostas.