Suporte » Ajustando o WordPress » Comentario precisa ser aprovado mesmo sem esta opção

  • Resolvido romarcio

    (@romarcio)


    Estou criando um blog e não marquei a opção para aprovação de comentários nem pelo administrador nem pelo autor.
    Nenhuma daquelas 2 opções está marcada e mesmo assim toda que um comentário é criado, aparece a mensagem de que deve ser aprovado pelo administrador e o comentário fica esperando aprovação.
    Será que é algum problema no arquivo comments.php?

    Fiz um teste trocando os temas para ver, e continua sempre com o mesmo problema.

Visualizando 11 respostas - 1 até 11 (de um total de 11)
  • Myst1010

    (@myst1010)

    No meu tema funciona perfeitamente, se está pedindo moderação ele mostra a mensagem se não ele libera o comentário direto.

    Estou usando em localhost a versão 3.0.5 e se vc está usando esta versão significa que não é problema no sistema e sim no tema.

    A dificuldade de te ajudar agora é que existe várias formas de fazer a página de comentários, mas no geral o código que exibe ou não essa mensagem é

    <?php if ($comment->comment_approved == '0') : ?>
    <p><em>Seu comentário está aguardando moderação</em></p>
    <?php endif; ?>

    Procure algo parecido com isso em seu arquivo comments.php ou em uma função no function.php do seu tema e veja se está igual.

    Se vc não encontrar esta parte em lugar nenhum seu tema usa os comentários padrões e ai eu já não sei dizer se ele está perfeito.

    no meu caso eu uso uma função para criar a área de comentários.

    Criador do tópico romarcio

    (@romarcio)

    Myst1010, no meu tema atual não tem esse bloco, nem no comments.php nem no function.php

    Mas como eu disse, alterei de tema e os outros temas que usei possuem esse bloco de código e mesmo assim da o problema. Estou usando a 3.0.5 localhost também.

    Tenho um blog no worpress mesmo, e ele funciona certinho, baixe o mesmo tema para testar localhost e não funcionou também.

    Os temas que eu testei foram o fusion e o catastrophe, o fusion é o que eu tenho o blog e funciona perfeito, mas como localhost não, da o mesmo problema mesmo tendo o bloco de código que vc citou.

    Myst1010

    (@myst1010)

    Que coisa estranha, fui testar aqui com cookie desabilitados pra ver se era este o problema e agora nem posso mais comentar porque dá a mensagem que estou comentando rápido demais.

    Mesmo voltando a habilitar os cookie o comentário não vai e aparece essa mensagem.

    Voltei na administração e marquei para precisar ser aprovado e mesmo assim nada.

    Usei outro navegador e a mesma coisa sendo que nunca fiz comentário por ele.

    Na outra instalação que tenho aqui e que não mudei nada disso está normal

    Creio que descobrimos um bug da versão sem querer, eu simplesmente não consigo mais fazer comentários.

    Criador do tópico romarcio

    (@romarcio)

    Esse problema do comentário rápido de mais aconteceu comigo também, mas achei que fosse algo normal do wordpress, pq comecei a usá-lo a pouco.
    Eu testei no chrome e no explorer 8, e nos dois da esse problema.

    Acho que vou remover tudo da instalação e começar do zero, desde a instalação do wordpress e do tema que pretendo usar.

    Mais tarde posto aqui o resultado.

    renato_s

    (@renato_s)

    Primeiro desative todos os plugins e teste novamente. 80% de chance de ser algum plugin dando conflito…

    Criador do tópico romarcio

    (@romarcio)

    Primeiro desative todos os plugins e teste novamente. 80% de chance de ser algum plugin dando conflito…

    Não deu tempo, já tinha excluído quando vc postou. Até agora não tive problemas, mas ainda não comecei a instalar os plugins que estava usando, quando fizer tudo como estava antes eu volto a dizer se o problema voltou ou não.

    Criador do tópico romarcio

    (@romarcio)

    Acho que encontrei o problema. Quando eu ativo o plugin Akismet, começa a dar o tal problema que citei.
    Vou dar mais uma testada, mas aparentemente parece ser isso.

    Myst1010

    (@myst1010)

    Os únicos plgins que estão instalados aqui são o wordpress-importer e Akismet, fora este não tem mais nenhum e ativado só o wordpress-importer e o erro continua.

    Criador do tópico romarcio

    (@romarcio)

    Eu tenho Akismet e o Dolly desativados, mas ativei o Akismet e dai começou a dar o problema, quando desativei ele parou.
    Obs: quando instalei a versão 3.0.5 o Akismet estava desatualizado, dai atualizei e foi ai que ativei e começou o problema até desativa-lo.
    Mas não tive muito tempo hj de mexer, amanhã vou encarnar nele de novo.

    Criador do tópico romarcio

    (@romarcio)

    Fiz mais alguns testes e pude confirmar que o problema era mesmo o Akismet .
    E acontece bem aquilo que já comentamos, quando ativado(apenas ativado não configurado), ele faz com que os comentários passem a exigir aprovação e caso tente publicar 2 comentários seguidos ele não deixa.
    Myst1010, vou deixar o post aberto, já que parece que com você o problema é outro, enquanto isso vou continuar testando pra ver se o problema não reaparece.

    Myst1010

    (@myst1010)

    É aqui eu não tenho ele ativado e nunca ativei e acontece o problema.

    Pra mim isso não é um problema porque eu não pretendo usar isso nunca desabilitado, mas seria interessante descobrir a causa para outros usuários que pretendam usar esta opção desta forma.

    Aqui eu já fiz vários testes e não voltou ao normal.

Visualizando 11 respostas - 1 até 11 (de um total de 11)
  • O tópico ‘Comentario precisa ser aprovado mesmo sem esta opção’ está fechado para novas respostas.