Suporte » Plugins » Cforms II – não chega o anexo no e-mail

  • Olá caríssimos,

    Venho pedir ajuda pois estou com problemas em meus formulários.
    Estava usando o Contact Form 7, mas do nada ele começou a ficar com a imagem ajax-loader.gif aparecendo constante após o envio da mensagem. O Email chega normalmente mas o cliente não recebe um retorno de mensagem enviada.
    Ai eu procurei e resolvi usar o Cforms II. Muito bom gerenciador de formulários, mas quando eu envio minha mensagem com 1 anexo, ele chega o nome do arquivo email mas não chega como anexo, ou seja, ele não envia a imagem.
    Se alguém puder me ajudar eu ficarei agradecido.
    Abraços.

Visualizando 15 respostas - 1 até 15 (de um total de 26)
  • Ele ta chegando direto na caixa de entrada ou como Spam?

    Thread Starter mottajr

    (@mottajr)

    Antes de mais nada obrigado pelo retorno Halane.
    Está chegando na caixa de entrada mesmo, mas chega com essa informação:
    Esta mensagem pode não ter sido enviada por: [E-mail removido por um moderador]

    Verifica se os anexos estão indo para a pasta /wp-content/plugins/cforms (É o padrão)

    Thread Starter mottajr

    (@mottajr)

    Me desculpe, mas onde eu vejo isso no código? pois na pasta não tem nada…

    Você colocou esse email nas configurações de SMTP e POP do plugin?

    Thread Starter mottajr

    (@mottajr)

    Me desculpe, mas é que sou novo no mundo WordPress e plugins…
    achei essa parte do código, seria aqui:

    <table class=”form-table”>
    <tr class=”ob space15″>
    <td class=”obL”><label for=”cforms_upload_dir”><?php _e(‘Upload directory (absolute path)’, ‘cforms’) ?></label></td>
    <td class=”obR”><input type=”text” id=”cforms_upload_dir” name=”cforms_upload_dir” value=”<?php echo $fileuploaddir; ?>”/> <?php _e(‘e.g. /home/user/www/wp-content/my-upload-dir’, ‘cforms’) ?></td>
    </tr>

    <tr class=”ob”>
    <td class=”obL”><label for=”cforms_upload_dir_url”><?php _e(‘Upload directory URL (relative path/URL)’, ‘cforms’) ?></label></td>
    <td class=”obR”><input type=”text” id=”cforms_upload_dir_url” name=”cforms_upload_dir_url” value=”<?php echo $fileuploaddirurl; ?>”/> <?php _e(‘e.g. /wp-content/my-upload-dir’, ‘cforms’) ?></td>
    </tr>

    <tr class=”ob space10″>
    <td class=”obL”><label for=”cforms_upload_noid”><?php _e(‘Disable noid- (tracking ID) prefix’, ‘cforms’) ?></label></td>
    <td class=”obR”><input class=”allchk” type=”checkbox” id=”cforms_upload_noid” name=”cforms_upload_noid” <?php if($cformsSettings[‘form’.$no][‘cforms’.$no.’_noid’]==’1′) echo “checked=\”checked\””; ?>/></td>
    </tr>

    <tr class=”ob space15″>
    <td class=”obL”><label for=”cforms_upload_ext”><?php _e(‘Allowed file extensions’, ‘cforms’) ?></label></td>
    <td class=”obR”><input type=”text” id=”cforms_upload_ext” name=”cforms_upload_ext” value=”<?php echo stripslashes(htmlspecialchars($cformsSettings[‘form’.$no][‘cforms’.$no.’_upload_ext’])); ?>”/> <?php _e(‘[empty=all files are allowed]’, ‘cforms’) ?></td>
    </tr>

    <tr class=”ob”>
    <td class=”obL”><label for=”cforms_upload_size”><?php _e(‘Maximum file size
    in kilobyte’, ‘cforms’) ?>
    </label></td>
    <td class=”obR”><input type=”text” id=”cforms_upload_size” name=”cforms_upload_size” value=”<?php echo stripslashes(htmlspecialchars($cformsSettings[‘form’.$no][‘cforms’.$no.’_upload_size’])); ?>”/></td>
    </tr>

    <tr class=”ob”>
    <td class=”obL”><label for=”cforms_noattachments”><?php _e(‘Do not email attachments’, ‘cforms’) ?></label></td>
    <td class=”obR”><input class=”allchk” type=”checkbox” id=”cforms_noattachments” name=”cforms_noattachments” <?php if($cformsSettings[‘form’.$no][‘cforms’.$no.’_noattachments’]==’1′) echo “checked=\”checked\””; ?>/>
    <?php echo sprintf(__(‘<u>Note</u>: Attachments are stored on the server & can be accessed via the cforms tracking tables.’, ‘cforms’),’?page=’. $plugindir.’/cforms-global-settings.php#tracking’,’onclick=”setshow(14)”‘); ?></td>
    </tr>
    </table>

    Você criou o formulário certo?
    Lá você colocou a opção de Anexo (tipo: file upload box

    Quando você adiciona essa opção e atualiza, em baixo aparece File Upload Settings … vai mostrar a pasta onde tão indo os anexos.

    Ela ta mostrando o diretório?

    Thread Starter mottajr

    (@mottajr)

    Para ser sincero Halane, agora que vi essa opção lá.
    Em em Global Settings tem a opção mail server settings onde tem a opção SMTP server address. Aqui no caso tenho que colocar o servidor smtp que está enviando o email??? seria isso mesmo??? Mas lá disse que em uma plataforma normal PHP eu não preciso definir esses dados… mas vou tentar configurar para vê se funciona…

    Thread Starter mottajr

    (@mottajr)

    está esse endereço: /agendacult5/Web/wp-content/plugins/cforms/attachments

    PHP MAILER:

    (GMAIL)
    MARCA Enable an external SMTP server
    SMTP server address: smtp.gmail.com
    SSL
    porta: 465

    POP
    MARCA POP before SMTP
    pop.gmail.com
    porta: 995

    Configura o email, envia um de teste… e verifica se nessa pasta está o anexo que você colocou.

    Também sou nova na área, usei agora o CForms II, eu encontrei uns problemas…mas, configurei tudo e ta indo normal.

    Thread Starter mottajr

    (@mottajr)

    Não está dando opção de configurar pop… só vai até o pop before smtp

    Marca a opção e salva as configurações que ela vai aparecer.

    Thread Starter mottajr

    (@mottajr)

    Pois é… estava usando o Contact Form 7 e estava ótimo… mas do nada ele começou a ficar com a imagem de upload constante na hora de enviar e não confirma o envio para o usuário. Ai tive que mudar para CForms II mas estou com muita dificuldade.

Visualizando 15 respostas - 1 até 15 (de um total de 26)
  • O tópico ‘Cforms II – não chega o anexo no e-mail’ está fechado para novas respostas.