Suporte » Plugins » Cadastro não funciona!

  • Resolvido fabiochexx

    (@fabiochexx)


    Pessoal, o problema é o seguinte. Quando um usuário preenche o cadastro de login na página de registro do Buddypress e clica em completar o registro, nada acontece. A página atualiza, mas continua na página de registro.

    Os registros funcionavam normalmente na versão 1.5.7 do BuddyPress, depois que atualizei para a ultima versão (1.6.3) não funciona mais. Tentei fazer o downgrade para as versões 1.5.7 e 1.5.6, em ambas o erro persistiu, e além deste erro apareceram novos erros em linhas de código.

    Status atual: Atualizei novamente para a versão 1.6.3, e estou desesperado buscando uma possível solução para o problema. O site está no ar, tem uma média de visitas relativamente alta e a propaganda da rede social foi pesada.

    Help, please! 🙂

Visualizando 6 respostas - 1 até 6 (de um total de 6)
  • Olá,

    Tente reescrever os links permanentes.

    Oi Diana, obrigado pela resposta. Eu já tentei criar páginas novas para a página de registro, alterei os links permanentes para outras formas disponíveis nas configurações no WP e não obtive sucesso.

    Quando você diz para reescrever os links permanentes, são essas alterações que devo fazer?

    A propósito, segue o link da página de registro que pode-se identificar o problema.

    http://cinebla.com.br/registrar/

    O problema não é constante, você pode tentar a primeira vez e conseguir efetivar o registro, porém ao tentar novamente, o problema aparece.

    Já tentei debugar a página de registro e não encontrei nada, comparei as funções com uma página de registro que funciona e nada!

    Obrigado.

    Funcionou de primeira.

    Será que não é falta de memória no servidor? Só o WP precisa de 256mb pra rodar sem problema algum.

    Tenta aumentar no php.ini se tiver ou pedindo para o serviço de hospedagem.

    Essa que é a questão, se você deslogar e tentar cadastrar um novo usuário, não funcionará mais.

    Chequei as configurações de memória do servidor, está em 256mb.

    Já esgotei minhas possibilidades, estou até pensando em procurar um plugin que integre o Buddypress com o Facebook e Twitter, para vincular o cadastro somente a estes meios.

    Obrigado pela ajuda.

    bj

    Então, 256MB é só para o WP, tente aumentar para 500mb, o BuddyPress precisa de memória ainda mais quando tiver muitos usuários.

    É uma boa usar registro/login pelo Facebook. Em geral, qualquer plugin de login social que funcione no WP vai funcionar no BuddyPress, mas há este que diz ser espcífico:
    http://buddydev.com/plugins/buddypress-facebook-connect-plus/

    (Dai você não mais usa as páginas de registro e ativar do BuddyPress)

    O http://wordpress.org/extend/plugins/facebook/ (oficial) ou o http://wordpress.org/extend/plugins/simple-facebook-connect/ parecem permitir cadastro/login pelo Facebook.

    Ver também:
    http://wp.smashingmagazine.com/2012/05/29/login-wordpress-using-social-network/

    Diana, consegui substituir o registro padrão pela conexão com redes sociais pelo plugin OA Social Login(http://wordpress.org/extend/plugins/oa-social-login/). Está funcionando direitinho.

    Porém, descobri um novo problema com o botão publicar comentário que não aparece mais. Mas detalharei isso em um novo tópico para não sujar o fórum.

    Bjo e obrigado pela ajuda.

Visualizando 6 respostas - 1 até 6 (de um total de 6)
  • O tópico ‘Cadastro não funciona!’ está fechado para novas respostas.