Suporte » Gerenciamento de conteúdo » Atualização parou de funcionar admin

  • Esse é o erro que aparece
    PHP Parse error: syntax error, unexpected ‘(‘ in E:\Domains\thepilatesfisiofitness.com.br\wwwroot\blog\wp-includes\functions.php on line 64

    na linha 64 aparece esse código
    return ( $gmt ) ? gmdate( ‘Y-m-d H:i:s’ ) : gmdate( ‘Y-m-d H:i:s’, ( time() + ( get_option( ‘gmt_offset’ ) * HOUR_IN_SECONDS ) ) );

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • olá @juniorfisio,

    qual a versão PHP de sua hospedagem?

    Ralden, onde verifico essa informação?

    Ralden, php v5.4.x essa é a versão da minha hospedagem!

    olá @juniorfisio,

    indico que solicite a hospedagem de seu WordPress atualização para PHP 7.x. a versão mais recente é a 7.3, mas nem toda hospedagem oferece a última versão. mas pelo menos peça para ir para PHP 7, isso provavelmente resolverá o problema.

    pelo menos pesquisando problemas semelhantes, a indicação de desenvolvedores foi que versões antiga do PHP, versão 5.x, costumam dar esse erro.

    pode inclusive apresentar esse erro para o suporte de sua hospedagem como justificativa para o pedido de mudança.

    saudações,

    Vou solicitar para ver se acho o erro!
    Obrigado até o momento

    @ralden eles disseram ser problema no blog, erro de código!

    olá @juniorfisio,

    olha, em condições normais, não se mexe em nada na pasta /wp-includes, pois é uma pasta mais para o core do WordPress. além disso, o erro aponta que é um “erro de sintaxe” referente ao PHP. ou você mexeu no arquivo e gerou o erro ou sua versão do PHP não interpreta o código corretamente. eu apostaria no segundo caso, especialmente porque a mudança de PHP 5 para 7 gerou novos códigos que o PHP 5 não entende e interpreta como erro. mas eu não sou programador, então não tenho certeza de nada quanto a isso.

    mas mesmo que o problema fosse de código, qual a questão para eles não atualizarem seu PHP para versão 7.x.???

    como eu disse, pesquisando o problema, na maioria dos casos foi relatado que a questão era com o PHP. além disso, já estamos na versão estável do PHP 7.3 (que inclusive é que eu uso, adoro o Runcloud justamente porque mudar a versão do PHP é apenas mudar uma opção), por isso o WordPress praticamente está indicando como requerimento mínimo o PHP 7.x, ou seja, 7.0.

    então se sua hospedagem se recusar a mudar a versão do PHP, ai eu pensaria seriamente em mudar de empresa… ou então precisará pensar em procurar um desenvolvedor/programador que verifique isso e ai sim dê certeza sobre o diagnóstico.

    talvez também seja o caso de desabilitar todos os plugins e usar um tema padrão, como o Twenty Nineteen, para ver se o erro some. eu não creio, mas o ideal é testar todas as possibilidades.

    saudações,

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • Você deve estar logado para responder a este tópico.