Suporte » Gerenciamento de conteúdo » Apóis instalar SSL WordPress bugou tudo

  • Resolvido supershopping

    (@supershopping)


    Olá galera após instalar o SSL pelo cloudflare meu site apresenta erros , demora pra carregar e não carrega todas imagens, como posso resolver.
    -Versao mais recente do wordpress
    -Tema: Shop Isle

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • saudações @supershopping,

    é preciso saber que configurações você ativou no Cloudflare. pelo cadeado, vejo que configurou corretamente o SSL através da seção “Crypto”.

    o problema é quando mexe em outras seções sem conhecimento. por exemplo, em “Speed”, tem lá as opções de “Auto minify” que podem causar problemas, assim como a “Rocket Laucher”.

    por padrão, essas opções que podem causar problemas ficam desabilitadas. então se estão ativas, foi porque as configurou assim.

    fora configurações com plugins de cache ou minificação, que tem que ser configurados com calma e testando os efeitos.

    eu apostaria que seu problema tem a ver com alguma configuração que mexeu com CSS e Javascript. pois tem dois ícones no canto superior, sendo o da direita o do carrinho, que não estão aparecendo. isso ocorre por vezes quando usa de minificação ou técnica agressivas para aumentar velocidade do site.

    espero ter ajudado. por favor nos informe se conseguiu resolver.

    se não, indico instalar o plugin Health Check

    https://br.wordpress.org/plugins/health-check/

    talvez lhe ajude a saber onde está o conflito.

    boa sorte!

    Gassho (mãos em prece), Namaste (eu lhe saúdo)

    Olá @supershopping,
    Grande @ralden,

    Abrindo a tela de ferramentas de desenvolvedor do Chrome (F12 no Windows), dá pra ver que há muitos arquivos estáticos (JS, CSS, imagens) com código de erro 522.

    O Cloudflare tem uma página com dicas de como resolver isso:

    https://community.cloudflare.com/t/community-tip-fixing-error-522-connection-timed-out/42325

    Basicamente, segundo essa página, esses arquivos estão sendo bloqueados na origem (hospedagem), ou seja, o Cloudflare consegue baixar a página mas não todos os arquivos que ela pede. É preciso investigar com a hospedagem se eles já fizeram o “whitelisting” dos IPs do Cloudflare.

    Às vezes acontece de o firewall no servidor da hospedagem ter comandos para limitar o acesso, por exemplo, no máximo X conexões por minuto de um único IP. Acontece que desde a instalação do Cloudflare que todas as conexões são via IPs do Cloudflare, então fica fácil o Cloudflare ser barrado por uma dessas regras.

    O ideal é a hospedagem habilitar o mod_remoteip para o seu site, assim o servidor vai receber o IP do visitante, e não o IP do Cloudflare, o que também evita esses problemas.

    @ralden Muito obrigado pelas dicas!! Felizmente o problema não era tão critico , bastou instalar o really simple SSL juntamente do cloudflare e ele arrumou o conteúdo misto.
    Mas muito obrigado 😉

    que ótima notícia @supershopping! peço apenas que finalize o tópico então, marcando-o como Resolvido.

    @cbrandt Olá CB, o conteúdo misto consegui arrumar com o really simple SSL, porém como você disse realmente esta ocorrendo o erro 522 (de tempo expirado do cloudflare), bem menos do que estava dando antes , mas mesmo assim as vezes acontece dele surgir principalmente quando fico muito tempo na parte admnistrativa.
    Vou tentar fazer pelo whitelisting e também irei verificar com a hospedagem como voce me indicou ,esse erro pelo que vi é bem comum no cloudflare e realmente pelo que pesquisei pode estar relacionado com o IP.
    Agradeço muito galera, e volto para dar um feedback caso der certo!
    Valeu
    😉

    @ralden Opa, pode deixar. Vou tentar resolver o erro 522 com as dicas do CB, caso nao der certo abro um topico especifico para esse problema.
    Obrigado

    Que bom um problema já foi resolvido!

    principalmente quando fico muito tempo na parte admnistrativa.

    O que pode ajudar com isso é vc criar no Cloudflare uma regra de página (page rule) para /wp-admin/

    URL: exemplo.com/wp-admin*
    Settings:
    Security Level: High
    Disable Apps
    Disable Performance

    Isso evita que a área administrativa sofra o impacto de alguns dos recursos do Cloudflare, inclusive os mencionados acima pelo @ralden, liberando no entanto vc para usar esses recursos normalmente para melhorar o desempenho do front end.

    Outra coisa que me ajudou muito a reduzir os erros 5XX do Cloudflare no meu site WP foi a adoção de um cronjob real, com a consequente desabilitação do pseudo-cronjob utilizado pelo WP. Pesquise no Google sobre “wordpress como criar cronjob real” que tem vários tutoriais explicando como fazer.

    • Esta resposta foi modificada 3 meses, 2 semanas atrás por  CB.
Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • Você deve estar conectado para responder a este tópico.