Suporte » Outros assuntos » Apenas a página Home está sem acesso

  • Resolvido leonardo2099

    (@leonardo2099)


    Estou montando um site WordPress para o cliente, e não é possível acessar a Home, quando tento acessar é feito um download qualquer. As demais páginas funcionam.

    Inicialmente o site estava ok, construí em meu próprio ambiente, quando passei para o ambiente do cliente começou a dar o seguinte problema: As páginas só eram acessadas se os links estivessem no modo padrão, se eu alterava os Links Permanentes, não conseguia mais.
    Do que consegui pesquisar, o apache não tinha o mod_rewrite instalado e precisava fazer alterações no arquivo 000-default.conf , não possuo permissão para alterar tais arquivos, solicitei para a TI do cliente que controla o servidor.
    Mod_rewrite foi instalado, e a seguinte informação foi colocada no 000-default.conf :

    <Directory “/var/www/html” >
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    Require all granted
    </Directory>

    Mas agora ocorre o problema descrito anteriormente. Consigo acessar as páginas sem precisar do id nas URLs, mas não consigo acessar a Home.

    O .htaccess está com a informação padrão do WordPress.

Visualizando 2 respostas - 1 até 2 (de um total de 2)
  • Criador do tópico leonardo2099

    (@leonardo2099)

    Mais uma informação, pesquisei e vi que na verdade não é apenas a Home, links estão com o id na URL também não estão acessíveis (ex: /?p=1360 )

    • Esta resposta foi modificada 4 anos, 8 meses atrás por leonardo2099.
    Criador do tópico leonardo2099

    (@leonardo2099)

    RESOLVIDO:
    O código que a equipe de TI colocou estava errado. O correto é

    
       <Directory "/var/www/html" >
         Options Indexes FollowSymLinks 
         AllowOverride All
         Require all granted
       </Directory>
    

    Agora está funcionando normalmente.

Visualizando 2 respostas - 1 até 2 (de um total de 2)
  • O tópico ‘Apenas a página Home está sem acesso’ está fechado para novas respostas.