Suporte » Ajustando o WordPress » Alterar redirecionamento de url

  • Resolvido charlesdesigner

    (@charlesdesigner)


    Saudações a todos!

    Atualizei meu sistema operacional do win 7 para win 10. Após feito a atualização o Apache parou de funcionar no xampp, então para resolver eu tive que mudar a porta de rede utilizada.

    Após alterar a porta só consigo acessar os meus projetos através da url localhost:122/nomedoprojeto, no caso, alterei a porta que era 80 para 122.

    Porém, quando tento acessar meus projetos com wordpress não é possível porque a url é redirecionada.

    Por exemplo: Se tento acessar http://localhost:122/padrao/, é redirecionado para http://localhost/padrao/, assim, acaba não carregando nada, fica em branco.

    Se fosse possível mudar a url de redirecionamento de http://localhost/padrao/ para http://localhost:122/padrao/ seria ótimo.

    Já tentei mudar diretamente no banco na tabela options o “home” e “siteurl”, mas não adiantou. Também tentei pelo functions.php e pelo wp-config.php, mas nada adiantou. Utilizei as linhas:

    wp-config.php:

    define('WP_HOME','http://exemplo.com');
    define('WP_SITEURL','http://exemplo.com');

    e no functions.php:

    update_option('siteurl','http://exemplo.com/blog');
    update_option('home','http://exemplo.com/blog');

    Existe algo que estou deixando de fazer ou que esteja fazendo errado?

Visualizando 2 respostas - 1 até 2 (de um total de 2)
  • Moderador Leo Baiano

    (@leobaiano)

    Como exatamente ficaram essas linhas no wp-config.php?

    define('WP_HOME','http://exemplo.com');
    define('WP_SITEURL','http://exemplo.com');
    Thread Starter charlesdesigner

    (@charlesdesigner)

    Olá Leo, obrigado pela sua atenção!

    Eu as coloquei logo abaixo da linha:
    define('DB_COLLATE', '');

    Mas, o problema foi resolvido a força! kkkk

    Apaguei o xampp, reinstalei ele e o projeto. Logo após, os comandos passaram a funcionar e pude dar continuidade no trabalho.

    O que estava acontecendo ao certo eu não pude descobrir, mas, resolvi na marra.

Visualizando 2 respostas - 1 até 2 (de um total de 2)
  • O tópico ‘Alterar redirecionamento de url’ está fechado para novas respostas.