Suporte » Ajustando o WordPress » “A resposta não é um JSON válido”.

  • Sempre que eu tento postar algo na minha página aparece a seguinte mensagem: “Falha ao agendar. Mensagem de erro: A resposta não é um JSON válido.”, fora que nem aparece a opção de “PUBLICAR” e sim a opção de “AGENDAR”.

    Por favor, gostaria de um auxílio para resolver esse problema.

    • Este tópico foi modificado 11 meses, 3 semanas atrás por Mario Valney. Motivo: Removida urgência
Visualizando 14 respostas - 1 até 14 (de um total de 14)
  • Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Olá, tudo bem?

    Se não aparece para publicar é porque a data do post está no futuro.

    Sobre o erro de JSON, parece ser algo de algum plugin.

    Consegue fazer um teste?
    Desative todos os plugins (ou pelo menos os de page-builder / editor / blocos) e tente publicar novamente.

    Se isso não resolver, tente publicar também usando o tema padrão do WordPress.

    Abraços,

    Olá! Tudo sim e contigo?

    Esse erro aconteceu a partir do momento em que criei o site, ou seja, eu não tinha nenhum plugin instalado. Instalei recentemente alguns plugins, incluindo um editor (Editor Clássico) que só através dele consegui fazer publicações. Porém, estou tentando criar uma página de formulário mas quando eu sou direcionada para está página través da opção “Contato” no Menu, aparece um erro e eu acredito que esta relacionado ao mesmo problema de JSON invalido. Até porque imaginei primeiramente que poderia ser um erro de plugin e fui até o suporte do plugin que instalei e vi uma opção que descrevia exatamente o que aparece na página que sou direcionada quando clico na opção “Contato” e o mesmo dizia que é um problema de JSON. Aliás, se eu desativo o plugin de editor de texto eu não consigo postar mais nada no meu site, nem publicações, nem criar páginas, enfim.

    • Esta resposta foi modificada 11 meses, 2 semanas atrás por laraflor.
    Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Olá.

    Se o problema aconteceu com uma instalação limpa (apenas o tema e plugin padrão), só pode ser algum problema no ambiente. 🙁

    Consegue testar em outro servidor ou hospedagem?
    Quem sabe no seu próprio computador com algum localhost (XAMP por exemplo).

    Prezado Mario Valney:
    Estou com o mesmo problema de erro: “Falha ao atualizar. Mensagem de erro: A resposta não é um JSON válido.”
    Estou em local host (XAMP).
    Estou no tema Twenty Seventeen.
    Não estou com nenhum plugin instalado.
    Zerei tudo.
    Mas ao tentar criar uma página nova, aparece o erro para publicar.
    Ao tentar colocar texto em uma página criada anteriormente, aparece o erro para atualizar.
    O que acontece? Como resolver este erro?

    Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Mauricio, consegue checar se tem algum erro no Chrome (ou no console)?
    Algo com script não carregado por conta de HTTPS/HTTP ou mesmo no console algum JS não carregado?

    Pesquisando, encontrei uma sugestão:
    tente ir em Configurações > Links permanentes e escolher outra opção, depois salvar e depois voltar para a que você está.

    Abraços

    Estava com o mesmo problema testei a ultima resposta do Mário e deu certo no meu site!

    Mauricio, consegue checar se tem algum erro no Chrome (ou no console)?
    Algo com script não carregado por conta de HTTPS/HTTP ou mesmo no console algum JS não carregado?

    Pesquisando, encontrei uma sugestão:
    tente ir em Configurações > Links permanentes e escolher outra opção, depois salvar e depois voltar para a que você está.

    • Esta resposta foi modificada 10 meses atrás por henrimf.

    Acabei de ter esse problema, depois de migrar de local para o servidor.
    Ao tentar atualizar uma página aparece a mensagem “A resposta não é um JSON válido”.
    No meu caso eu tive que reenviar o arquivo htaccess

    • Esta resposta foi modificada 9 meses, 3 semanas atrás por Minoru Takatori.

    Eu estava com o mesmo problema ao publicar posts, ai fiz o que o Mário Valney falou, mudar a configuração dos Links Parmenentes e boooom… funcionou perfeitamente! Vlw <3

    Estava com o mesmo problema testei a resposta do Mário,mudar a configuração dos Links Permanentes e deu certo no meu site!

    Reinaldo Nani

    (@reinaldonani)

    Aqui tive o mesmo problema e graça a dica de acessar Opções > Ligações Permanentes > Nome do artigo. No meu caso ficou perfeito e não tive de mexer nos plugins. Muito obrigado!!!!

    Bom, espero que esteja utilizando um servidor apache!

    Esse problema é um problema de configuração do apache, faça o seguinte:

    Navegue até a configuração do VirtualHost do seu site no apache:
    cd /etc/apache2/sites-available

    Edite o arquivo 000-default.conf ou crie um para o seu site meusite.com.br.conf

    Coloque a seguinte instrução nele:

    <VirtualHost *:80>
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html
    
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
    
    <Directory /var/www/html/meusite>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>
    
    </VirtualHost>

    Ative os novos arquivos de Virtual Host
    sudo a2ensite meusite.com.br.conf

    Verifique se o arquivo /…/meusite/.htaccess existe e se o WordPress pode escrever nele, uma forma simples de descobrir é acessando Painel>Configurações>Links Permanentes e observando se há alguma mensagem do WordPress referente ao .htaccess. Se você ver a mensagem abaixo, significa que seu .htaccess não pode ser escrito: Para resolver este problema, altere as permissões do arquivo, o recomendado pelo wordpress é 644:
    ~$ sudo chmod 644 .htaccess

    No entanto, se o WordPress ainda assim exibir a mensagem acima use temporariamente uma permissão maior, como 755. Depois de ajustar as permissões tente alterar o formato dos permalinks e verifique se o WordPress escreveu no arquivo:

    O conteúdo do arquivo .htaccess deve ser algo assim:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /site/
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /site/index.php [L]
    </IfModule>
    #END WordPress
    

    Note no início do arquivo: <IfModule mod_rewrite.c> isto verifica se o módulo do apache mod_rewrite.c está habilitado, se não estiver o apache ignorará os comandos seguintes do arquivo. Para verificar se o módulo está ativado use:
    ~$ ls /etc/apache2/mods-enabled/

    Se rewrite.load não constar na lista, o módulo está desabilitado (estranhamente no Ubuntu, este módulo vem desativado). Para habilitar o módulo use o comando:
    ~$ sudo a2enmod rewrite

    Reinicie o Apache, você já poderá alterar a estrutura de links permanentes em seguida que deverá funcionar.
    ~$ sudo systemctl restart apache2

    Prontinho, viu como é simples?

    Me acompanha no meu canal que depois faço um vídeo a respeito desse problema Canal do Youtube Gil HHB

    • Esta resposta foi modificada 4 meses, 2 semanas atrás por Mario Valney. Razão: Códigos

    Segui a dica do Mário Valney

    “Mauricio, consegue checar se tem algum erro no Chrome (ou no console)?
    Algo com script não carregado por conta de HTTPS/HTTP ou mesmo no console algum JS não carregado?

    Pesquisando, encontrei uma sugestão:
    tente ir em Configurações > Links permanentes e escolher outra opção, depois salvar e depois voltar para a que você está.”

    nunesnd

    (@nunesnd)

    Agradeço o @gilhhb teu tutorial salvou horas de trabalho.

    adicionei conteúdo que faltou do 000-default.conf
    mudei as permissões de arquivo meusite/.htaccess (que o mesmo existia e estava com o conteúdo devido
    mudei a permissão e
    reiniciei o apache

    testei criação de páginas e posts, tudo funcionou como deveria

    Muito obrigado.

    Estava com esse problema há semanas, inclusive dando erro de JSON no plugin do Google Site Kit, que impedia a verificação do site e instalação completa do plugin. Fiz o que o Mário falou de mudar os links permanentes e deu super certo! Obrigada pela ajuda!

Visualizando 14 respostas - 1 até 14 (de um total de 14)
  • Você deve estar conectado para responder a este tópico.