Finalmente a tradução do 2.8.1

Um pouco atrasados, mas finalmente lançamos a versão pt_BR do WordPress 2.8.1. Esta versão corrige alguns bugs de acordo com o post de lançamento escrito por Ryan Boren, traduzido abaixo. Nossa tradução também corrige alguns erros encontrados na versão 2.8 (obrigado Eduardo Zulian e Rafael Fischmann pelo feedback!).

O WordPress 2.8.1 corrige vários bugs e aumenta a segurança das páginas de administração de plugins. Core Security Technologies nos avisou que as páginas de admin adicionadas por alguns plugins poderiam ser vistas por usuários sem privilégios, resultando em vazamento de informações. Nem todos os plugins são vulneráveis a esse problema, mas nós aconselhamos a atualização para o 2.8.1 por segurança.

O que mais há de novo desde o 2.8? Leia os destaques abaixo, ou veja todas as mudanças desde o 2.8

  • Certos temas estavam chamando a função get_categories() de forma que ela falhava no 2.8. O 2.8.1 resolveu isso para que os temas não tenham que ser alterados.
  • O uso de memória do painel foi reduzido. Algumas pessoas ficavam sem memória ao carregar o painel, o que resultava em uma página incompleta.
  • O upgrade automático não apaga mais acidentalmente arquivos ao fazer limpeza de uma atualização falha.
  • Um problema onde o editor visual de texto não era carregado devido a questões de compressão foi resolvido.
  • Segurança extra foi adicionada para melhor proteção contra plugins que não explicitam verificações de permissão.
  • Tradução dos nomes das funções corrigidas.
  • O padrão do wp_page_menu() lista as páginas de acordo com a ordem especificada pelo autor ao invés do título da página.
  • As mensagens de erros de upload agora estão corretamente relatadas.
  • O erro de salvamento automático experimentado por alguns usuários do IE foi corrigido.
  • Erro de estilo no editor de plugin corrigido.
  • Requisitos de sistema de arquivos SSH2 atualizados.
  • Voltamos ao curl como padrão de transporte.
  • Atualizada a biblioteca de tradução para evitar problema com o mbstring.func_overload.
  • Limpeza de estilos no meio do código mais rigorosa.
  • Segurança do menu mais rigorosa.
  • O destaque de código foi desativado devido a incompatibilidades de navegadores.
  • Correções de layout RTL.

WordPress 2.6.3 traduzido

Acabamos de lançar o WordPress2.6.3 traduzido para o português brasileiro. Esse release é uma atualização de segurança. De acordo com a nota oficial no Development Blog (traduzido por Cátia Kitahara):

Uma vulnerabilidade na biblioteca Snoopy foi anunciada ontem. O WordPress usa o Snoopy para coletar os feeds mostrados no painel. Embora aparentemente seja uma vulnerabilidade de baixo risco para os usuários do WordPress, nós quisemos uma atualização imediata. O 2.6.3 está disponível para download agora. Se você não quiser fazer o download de todo o pacote para ter a correção de segurança, você pode fazer o download dos dois seguintes arquivos e substituir os que se encontram em sua instalação do 2.6.2:

  1. wp-includes/class-snoopy.php
  2. wp-includes/version.php

O mesmo vale para a versão em português do Brasil.

Lançado o WP 2.6.1 pt_BR

Com apenas dez dias de atraso lançamos o WP 2.6.1 traduzido. E apesar de terem sido apenas DEZ dias de atraso já teve gente reclamando e se perguntando se nós “já desistimos”.

Portanto, aviso aos navegantes, NÃO, NÓS, A COMUNIDADE WORDPRESS-BR, AINDA NÃO DESISTIMOS DE CONTINUAR TRADUZINDO O WORDPRESS PARA O PORTUGUÊS DO BRASIL OFICIALMENTE, apesar da comunidade hoje se resumir a praticamente uma voluntária (esta que vos fala), e de ter mais gente cobrando e querendo suporte do que gente disposta a ajudar.

WordPress 2.6 em Português do Brasil!

Perdi a aposta com os amigos portugueses, mas o que importa é que consegui lançar a tradução do WordPress 2.6 com apenas 9 horas de diferença em relação ao release original. Está bom, não? Prá quem antes nunca tinha uma tradução oficial!

A equipe de desenvolvedores do WordPress preparou um breve vídeo-tur do 2.6, se você tiver 3 minutos e 29 segundos para perder, vale à pena assistir.

Tradução da versão 2.5.1 já está disponível

A versão 2.5.1 pt_BR já está disponível. Abaixo, uma tradução do post do Ryan no blog WordPress, com explicações sobre essa nova versão.

Ela inclui vária correções, melhorias de desempenho, e uma correção de segurança muito importante. Nós recomendamos que todos façam a atualização imediatamente, particularmente se o seu blog possui o registro aberto. A vulnerabilidade não é de conhecimento público, mas logo será.

Além da correção de segurança, o 2.5.1 contém várias correções de erros. Se você estiver interessado somente nas correções de segurança, você pode fazer o download dessas cópias corrigidas dos arquivos wp-includes/pluggable.php, wp-admin/includes/media.php, e wp-admin/media.php. Substitua as suas cópias existentes por essas novas.

Se você fizer o download da versão 2.5.1 completa, você terá mais de 70 correções. A versão 2.5.1 tem por objetivo a correção dos erros mais chatos e a melhoria do desempenho. Abaixo destacamos:

  • Melhorias de performance para as páginas Painel, Escrever Post e Editar Comentários.
  • Melhor desempenho para quem tem vários comentários
  • Correções da ferramente de upload de mídia
  • Uma atualização para o TinyMCE 3.0.7
  • Correções de administração de widgets
  • Vária melhorias de usabilidade
  • Correções de layout para o IE

Vida Secreta dos Blogs

Desde o 2.5 o seu arquivo wp-config.php permite uma nova constante chamada SECRET_KEY, que basicamente existe para introduzir uma pequena aleatoriedade permanente nas funções de criptografia, usadas pelos cookies no WordPress. Você pode visitar esse link que nós disponibilizamos para criar uma única chave secreta para seu arquivo config. (Ela é única e aleatória cada vez que a página é carregada). Ter essa linha no seu arquivo config ajuda a manter seu blog seguro.

Muito obrigada a Steven Murdoch por responsavelmente relatar o problema de segurança (CVE-2008-1930) e a Alex Concha por relatar um problema XSS.