WordPress.org

News

Atualização da versão mínima do PHP

Atualização da versão mínima do PHP


O lançamento do WordPress 5.2 está previsto para o fim deste mês e, com ele, virá a atualização da versão mínima necessária do PHP. O WordPress agora precisará do PHP 5.6.20, no mínimo.

A partir do WordPress 5.1, os usuários executando versões do PHP anteriores à 5.6 receberam uma notificação no Painel exibindo informações sobre como atualizar o PHP. Desde então, as estatísticas do WordPress mostraram um aumento de usuários com versões mais recentes da linguagem.


Widget que os usuários veem no Painel ao usar versões antigas do PHP

Por que você deve atualizar o PHP

Se seu site está usando uma versão de PHP sem suporte, o gerenciador de atualizações do WordPress não oferecerá a versão 5.2. Se você tentar atualizar o WordPress manualmente, a atualização falhará. Para continuar a usar os recursos mais recentes do WordPress, antes será necessário atualizar para uma versão mais recente do PHP.

Se precisar escolher uma versão mais nova do PHP, o WordPress encoraja a atualização para a versão recomendada, PHP 7.3. A equipe do PHP fez um excelente trabalho, tornando esta versão a mais rápida de todas. Isso significa que atualizar o PHP melhorará a velocidade do seu site, tanto para você quanto para seus visitantes.

Com essa melhora no desempenho, menos recursos de servidor são necessários para hospedar os sites. Atualizar o PHP não é bom só para o seu site, isso também significa que menos energia é necessária para o terço da internet que usa o WordPress, logo isso também é uma coisa boa para o planeta.

Como atualizar o PHP

Se você precisa de ajuda para atualizar a sua versão de PHP, disponibilizamos uma documentação detalhada para isso. Ela inclui modelos de comunicação que você pode enviar à sua empresa de hospedagem para que eles possam ajudar. Muitas empresas já publicaram informações específicas de como atualizar o PHP em seus serviços (em inglês).

5.6 agora, 7+ em breve

Esta é a primeira atualização na versão mínima do PHP para o WordPress desde 2010, mas pode não ser a única em 2019. A equipe dos arquivos básicos do WordPress monitorará a adoção de versões mais recentes do PHP analisando a possibilidade de tornar o PHP 7+ a versão mínima obrigatória até o fim do ano.

Atualize o PHP hoje para poder atualizar o WordPress amanhã!