WordPress 5.2 Release Candidate

O primeiro release candidate (versão candidata, em tradução livre) do WordPress 5.2 já está disponível!

Essa é uma marca importante, significa que estamos cada vez mais próximos da data de lançamento do WordPress 5.2. “Versão candidata” significa que a nova versão está pronta para lançamento, mas com milhões de usuários e milhares de plugins e temas, é possível que ainda exista algum problema. O lançamento do WordPress 5.2 está agendado para terça-feira, 7 de maio, mas precisamos da sua ajuda para que isso aconteça. Se você ainda não testou a versão 5.2, a hora é essa!

Existem duas formas de testar o WordPress 5.2 release candidate: com o plugin WordPress Beta Tester (você deve usar “bleeding edge nightlies”) ou você pode baixar a versão aqui (zip).

Quais são as novidades do WordPress 5.2?

Continuando as melhorias da última versão, o WordPress 5.2 trará ferramentas ainda mais robustas para identificar e corrigir problemas de configuração e erros fatais. Seja você um desenvolvedor ajudando seus clientes ou alguém que está gerenciando o próprio site, estas ferramentas podem ajudar a obter a informação que você precisa, quando você precisa.

O Diagnóstico do site e as ferramentas de proteção contra erros de PHP trazem novos recursos, dando paz de espírito para quem descobrir qualquer problema com plugins e temas no site. Também existem atualizações nos ícones disponíveis no seu painel, melhorias na acessibilidade para os que usam tecnologias assistivas e muito mais.

Desenvolvedores de plugins e temas

Teste seus plugins e temas com o WordPress 5.2 e atualize para 5.2 a versão no campo Tested up to do arquivo readme. Se encontrar problemas de compatibilidade, tenha certeza de publicar no fórum para que possamos agir antes do lançamento final.

O Guia do WordPress 5.2 também foi publicado, detalhando as maiores mudanças da versão.

Como ajudar

Ajude a tradução em Português! Ajude-nos a traduzir o WordPress para o português! O lançamento dessa versão também significa que novas strings para tradução da versão 5.2 serão evitadas.

Se acha que encontrou um erro, você pode publicá-lo na área Alpha/Beta nos fóruns de suporte (em inglês). Nós vamos adorar ouvir você! Se você se sente confortável para escrever um relatório de como reproduzir o erro, envie para o Trac do WordPress, onde também é possível encontrar uma lista de erros conhecidos.


Olá, RC 1!
Com ferramentas tão interessantes,
Eu mal posso esperar.

WordPress 5.2 Beta 3

O WordPress 5.2 Beta 3 já está disponível!

Esta versão ainda está em desenvolvimento, portanto não recomendamos seu uso em ambientes de produção. Considere criar um site de testes para testar a nova versão.

Existem duas formas de testar a versão beta mais recente do WordPress 5.2: com o plugin WordPress Beta Tester (você deve usar “bleeding edge nightlies”) ou você pode baixar a versão aqui (zip).

O lançamento do WordPress 5.2 está previsto para 30 de abril e precisamos da sua ajuda para que isso aconteça. Graças aos testes e comentários recebidos de quem testou o beta 2, aproximadamente 40 tickets foram fechados desde então. Aqui estão as maiores mudanças e correções de erros:

  • O novo recurso de Diagnóstico do site continua sendo melhorado.
  • Os plugins não atualizam mais se o site está executando uma versão PHP sem suporte (#46613).
  • Agora está mais fácil identificar quando um site está sendo executado em Modo de restauração (#46608).
  • O botão para escrever sem distrações não quebra mais a navegação por teclado no Editor clássico (#46640).
  • O uso de tecnologias assistivas foi melhorado anunciando submenus da barra de administração (#37513).
  • Os assuntos dos e-mails enviados pelo WordPress estão mais consistentes (#37940).
  • As exportações de dados pessoais agora são exibidas como concluídas apenas quando um usuário baixa seus dados (#44644).
  • Melhorias adicionais na acessibilidade (#35497 e #42853).

Atualização da versão mínima do PHP

Lembrete importante: A partir do WordPress 5.2 beta 2, a versão mínima necessária do PHP será a 5.6.20. Se você está executando uma versão mais antiga do PHP, nós recomendamos atualizá-la agora, antes que o WordPress 5.2 seja oficialmente lançado.

Notas para desenvolvedores

O WordPress 5.2 tem várias pequenas melhorias para melhorar a experiência de desenvolvimento. Para manter-se atualizado, assine o blog Make WordPress Core com especial atenção para as notas para desenvolvedores para atualizações sobre essas e outras mudanças que podem afetar seus produtos.

Como ajudar

Ajude a tradução em Português! Ajude-nos a traduzir o WordPress para o português! O lançamento da versão beta 3 também significa que novas strings para tradução da versão 5.2 serão evitadas.

Se acha que encontrou um erro, você pode publicá-lo na área Alpha/Beta nos fóruns de suporte (em inglês). Nós vamos adorar ouvir você! Se você se sente confortável para escrever um relatório de como reproduzir o erro, envie para o Trac do WordPress, onde também é possível encontrar uma lista de erros conhecidos.


O que você procuraria
cada dia mais perto do lançamento
esteja pronto testando
.

WordPress 5.2 Beta 2

O WordPress 5.2 Beta 2 já está disponível!

Esta versão ainda está em desenvolvimento, portanto não recomendamos seu uso em ambientes de produção. Considere criar um site de testes para testar a nova versão.

Existem duas formas de testar o WordPress 5.2 beta 2: com o plugin WordPress Beta Tester (você deve usar “bleeding edge nightlies”) ou você pode baixar a versão aqui (zip).

O lançamento do WordPress 5.2 está previsto para 30 de abril e precisamos da sua ajuda para que isso aconteça. Graças aos testes e comentários recebidos de quem testou o beta 1, aproximadamente 100 tickets foram fechados desde então. Aqui estão as maiores mudanças e correções de erros:

  • Adicionamos suporte para Emoji 12! 🪂
  • Uma novíssima template tag, wp_body_open(), (e uma ação wp_body_open correspondente) permitirá que temas e plugins adicionem conteúdo logo depois da abertura da tag <body> (#12563).
  • Tags de parágrafo desnecessárias deixaram de aparecer no conteúdo dinâmico dos blocos (#45495).
  • As telas do Diagnóstico receberam várias correções, ajustes e melhorias de desempenho.
  • A proteção contra travamentos deixou de interromper a edição de plugins (#46045).
  • O tratamento personalizado de erros agora carrega corretamente (#46069).

Atualização da versão mínima do PHP

No WordPress 5.2 beta 2, a versão mínima necessária do PHP será a 5.6.20. Se você está executando uma versão mais antiga do PHP, nós recomendamos atualizá-la agora, antes que o WordPress 5.2 seja oficialmente lançado.

Notas para desenvolvedores

O WordPress 5.2 tem várias pequenas melhorias para melhorar a experiência de desenvolvimento. Para manter-se atualizado, assine o blog Make WordPress Core com especial atenção para as notas para desenvolvedores, que trazem atualizações sobre essas e outras mudanças que podem afetar seus produtos.

Como ajudar

Ajude a tradução em Português! Ajude-nos a traduzir o WordPress para o português!

Se acha que encontrou um erro, você pode publicá-lo na área Alpha/Beta nos fóruns de suporte (em inglês). Nós vamos adorar ouvir você! Se você se sente confortável para escrever um relatório de como reproduzir o erro, envie para o Trac do WordPress, onde também é possível encontrar uma lista de erros conhecidos.


A coisa boa
sobre betas, é que betas
são uma coisa boa.
🐯

Atualização da versão mínima do PHP

O lançamento do WordPress 5.2 está previsto para o fim deste mês e, com ele, virá a atualização da versão mínima necessária do PHP. O WordPress agora precisará do PHP 5.6.20, no mínimo.

A partir do WordPress 5.1, os usuários executando versões do PHP anteriores à 5.6 receberam uma notificação no Painel exibindo informações sobre como atualizar o PHP. Desde então, as estatísticas do WordPress mostraram um aumento de usuários com versões mais recentes da linguagem.


Widget que os usuários veem no Painel ao usar versões antigas do PHP

Por que você deve atualizar o PHP

Se seu site está usando uma versão de PHP sem suporte, o gerenciador de atualizações do WordPress não oferecerá a versão 5.2. Se você tentar atualizar o WordPress manualmente, a atualização falhará. Para continuar a usar os recursos mais recentes do WordPress, antes será necessário atualizar para uma versão mais recente do PHP.

Se precisar escolher uma versão mais nova do PHP, o WordPress encoraja a atualização para a versão recomendada, PHP 7.3. A equipe do PHP fez um excelente trabalho, tornando esta versão a mais rápida de todas. Isso significa que atualizar o PHP melhorará a velocidade do seu site, tanto para você quanto para seus visitantes.

Com essa melhora no desempenho, menos recursos de servidor são necessários para hospedar os sites. Atualizar o PHP não é bom só para o seu site, isso também significa que menos energia é necessária para o terço da internet que usa o WordPress, logo isso também é uma coisa boa para o planeta.

Como atualizar o PHP

Se você precisa de ajuda para atualizar a sua versão de PHP, disponibilizamos uma documentação detalhada para isso. Ela inclui modelos de comunicação que você pode enviar à sua empresa de hospedagem para que eles possam ajudar. Muitas empresas já publicaram informações específicas de como atualizar o PHP em seus serviços (em inglês).

5.6 agora, 7+ em breve

Esta é a primeira atualização na versão mínima do PHP para o WordPress desde 2010, mas pode não ser a única em 2019. A equipe dos arquivos básicos do WordPress monitorará a adoção de versões mais recentes do PHP analisando a possibilidade de tornar o PHP 7+ a versão mínima obrigatória até o fim do ano.

Atualize o PHP hoje para poder atualizar o WordPress amanhã!