WordPress 4.8 não dará mais suporte para IE 8, 9 e 10

Publicado em por . Arquivado em Geral.

No fim de semana do dia 22 de abril, Matt Mullenweg anunciou que a versão 4.8 do WordPress não terá mais suporte para as versões 8, 9 e 10 do IE. Duas semanas antes, o suporte a navegadores foi discutido pelos colaboradores para definir os requisitos técnicos para o novo editor.

A Microsoft descontinuou o suporte para os IE 8, 9 e 10 em janeiro de 2016, o que significa que estas versões não recebem mais atualizações de segurança. Mullenweg disse que a tentativa de continuar dando suporte para estes navegadores está impedindo o avanço do desenvolvimento do WordPress.

“Acredito que o pessoal com estes navegadores provavelmente está preso a eles por algum motivo fora de seu controle, como estar em uma biblioteca ou coisa assim”, disse Mullenweg. “Dependendo de como você conta, estes navegadores juntos estão sendo usados por volta de 3% ou menos que 1% do total de usuários, mas, de qualquer forma, eles ficaram abaixo da linha de corte onde é útil ao WordPress continuar se desenvolvendo”.

Em um esforço para determinar quantas pessoas continuam usando estes navegadores inseguros e obsoletos, Jonathan Desrosiers coletou dados de três fontes diferentes. Os números abaixo representam o uso global do IE publicado pela StatCounter’s GlobalStats, que segundo Desrosiers são praticamente idênticos aos números do WordPress.com:

  • IE8: 0,41%
  • IE9: 0,26%
  • IE10: 0,26%
  • IE11: 3,79%

O WordPress não parará completamente de funcionar nestes navegadores, mas depois do lançamento da versão 4.8 os colaboradores não testarão novos recursos em versões antigas do IE. Algumas funções do painel poderão ser mais limitadas. Mullenweg confirmou que as próximas versões do TinyMCE não darão mais suporte para versões anteriores do Internet Explorer.

O uso global do IE caiu de 7,44% em março de 2016 para 4,18% em março de 2017. Com o aumento do uso de dispositivos móveis a participação do IE neste mercado vem diminuindo. Outubro de 2016 foi o primeiro mês na história no qual o tráfego oriundo de celulares e tablets ultrapassou o de desktops. Com esta tendência de queda do uso de desktops, o IE será praticamente enterrado em alguns anos.

“Fui bastante pressionado a encontrar uma agência governamental americana rodando uma versão do IE mais baixa que a 11”, comentou Andrew Nacin, líder de desenvolvimento do WordPress, durante o anúncio. “Sites de agências governamentais também veem tráfego insignificante vindo de versões do IE menores que a 11”.

A decisão de parar com o suporte a versões 8, 9 e 10 do IE foi recebida com celebração pela comunidade de desenvolvedores do WordPress. Concentrar-se em navegadores que ainda recebem atualizações de segurança é um uso melhor de tempo e recursos dos colaboradores de ferramentas de código aberto. Esta política de suporte do WordPress ao IE também pode ser usada como argumento por desenvolvedores que atendem a clientes que pedem por suporte a navegadores inseguros.

Naturalmente, o tópico sobre aumentar requisitos mínimos dos navegadores resultou no lobby de desenvolvedores para acabar com o suporte para o PHP 5.2, que teve sua vida encerrada há seis anos. Em março de 2015, estatísticas do WordPress estimaram em 16, 6% o uso do PHP 5.2, mas o número caiu drasticamente para 5,1% hoje. A tarefa de atualizar um navegador para sua última versão é fácil para os usuários, mas atualizar versões do PHP ainda é um pouco complicado para aqueles que não recebem ajuda de suas empresas de hospedagem. Os 5,1% usando PHP 5.2 representam milhões de usuários que precisariam transpor um obstáculo significativo para poder usar a última versão do WordPress.

Traduzido de https://wptavern.com/wordpress-4-8-will-end-support-for-internet-explorer-versions-8-9-and-10